Support » Fixing WordPress » Automatic plugin update doesn't display progress

  • When I try to use the automatic plugin update feature, the only progress that’s displayed is that the plugin is being downloaded. There rest of the display never appears, but if I check, the plugin has in fact been updated.

    The feature works as it should on my localhost server development machine, but not on the live site which is hosted on BlueHost. I’m wondering if it’s a permissions issue.

    Thanks for any help resolving this.

Viewing 12 replies - 1 through 12 (of 12 total)
  • bump

    I am wondering if a plugin or theme you currently have installed is interfering with it. I have several installations myself on BlueHost and none of them have this problem.

    Try installing a new WordPress installation into a test folder and install an outdated plugin, then update it through there and see if you can replicate it.

    Also try changing your theme to the twentyten theme and disabling all plugins (except for one which needs to be updated) and see if that one seems to update successfully.

    Also check your php.ini and see what your memory_limit is set to. 64M should be good.

    I actually have had the same problem since wp 3.0. For plugin or core updates.

    I see no progress, and it never appears to finish

    Its not related to plugins, or themes on my end

    I’m not too concerned about it really since everything gets updated

    If I ever figure out how to fix it, that’d be cool…

    Maybe we can find a common factor here. Mine work, but I’d be interested to see why both of yours don’t. I’ll play with some test installs in some subfolders and subdomains and see if I can replicate the issue there.

    I tried some existing installs and some new tests and couldn’t replicate it. I tested with the main domain, subfolders, subdomains, and on a MultiSite install. All of them worked. I’m wondering if some .htaccess code could be contributing to it. Or perhaps a memory_limit setting?

    All of my sites hosted on godaddy do not work.

    One in root, one in subdirectory, 1 subdomain, and 2 in routed domains in subdirectories.

    All different plugins, all different themes. Nothing common between them….. except godaddy

    On my self-hosted site, everything is fine (its a multisite).

    So I’ve found my common denominator (however that is not the case with teh OP)

    I have a similar problem, but nothing ever updates. I click on the “update automatically”,changes pages, but does absolutely nothing. Even after updating the 3.0 – now it’s asking me to update to 3.01. I’ve deleted all my plugins and all my themes except for twenty ten and it still won’t update. Any advice?

    Yes, it’s not a big deal in the sense that the plugin does get updated, but if you have more than one to update, there’s no way of telling if the update has actually completed prior to going back to the plugin list page.

    That is the pain, I just let it run for a bit…lol, less than ideal!

    I don’t think it’s a permissions issue, but if it is, and if you have SSH access, you could try the following two commands:

    find ~/public_html -type d -exec chmod 755 {} \;
    find ~/public_html -type f -exec chmod 644 {} \;

    Some hosts may need 777 permissions but, as that can be insecure, I’d suggest trying 755 for directories and 644 for files first. Also, try a test install and see how that one manages.

    For anyone else who might drop in with the same issue, it would still be wise to deactivate plugins and change the theme to twentyten before trying anything else.

    I get the same message. Just says downloading… and not other progress.
    using 3.0.1 on 1and1 hosting
    it happens whenever i try to download something:
    theme / widget / plugin

    Please help

    I have 2 separate linux vps’ and run wordpress on both of them. One of the servers runs the automatic updates fine – displays the progress and automatically restarts plugins. The other server runs the updates but does not display the progress and does not automatically restart updated plugins. I had racked my brain trying to figure it out. Both servers run php5 with the exact same settings. I tried to visually compare the php.ini files but that was no help. So today I downloaded the php.ini file from the server that worked fine and uploaded (over wrote) the file to the server that did not work so well. Now it works great so it is definitely a php configuration issue. I’m sorry that I can’t tell you exactly what it is. If I had to guess its either something to do with the fopen setting or is something to do with the script execution settings – time allowed, memory usage.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Automatic plugin update doesn't display progress’ is closed to new replies.