Support » Plugin: DsgnWrks Instagram Importer » Automatic import not automatically importing

  • The title says it all: Automatic import not automatically importing

    I have laboriously deleted and recreated my user to no avail. My Instagram Importer is not triggering automatically.

    Here is the configuration. What am I missing?

    • This topic was modified 1 year, 10 months ago by  Wes Modes.
Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Justin Sternberg

    (@jtsternberg)

    The automatic import is dependent on the WordPress pseudo-cron system working properly. This post does a decent job of explaining possible problems with that: https://wpengine.com/support/wp-cron-wordpress-scheduling/

    Plugin Author Justin Sternberg

    (@jtsternberg)

    Hi Justin, thanks for this.

    I was able to verify that wp-cron is running:

    peoplesriverhistory.us 172.19.25.232 - - [30/Jul/2017:07:47:41 +0000] (0 s) "POST /wp-cron.php?doing_wp_cron=1501400861.9247078895568847656250 HTTP/1.1" 200 20 "http://peoplesriverhistory.us/wp-cron.php?doing_wp_cron=1501400861.9247078895568847656250" "WordPress/4.7.5; http://peoplesriverhistory.us"

    Which is consistent with my scheduled posts working.

    Is there anything specifically regarding Instagram Importer I can look for in the logs?

    What else can I check that Importer is dependent on?

    Wes

    Plugin Author Justin Sternberg

    (@jtsternberg)

    Hmm maybe put this file in your wp-content/mu-plugins folder. It will log when the instagram importer fires: https://gist.github.com/jtsternberg/1f3ef57a18264501b5acf19f85cae003
    (for this to work, you need to make sure WP_DEBUG and WP_DEBUG_LOG are enabled).

    For what it’s worth, the scheduled importing is working fine on my site, so it’s likely server specific. Let me know what you see in the log after this should have run a few times.

    It was working on my site/server automatically. Though I am unsure whether it was an update or other config/plugin addition that caused it to stop automaticing.

    I’ll try the file. Will it report if the Importer tries and fails?

    I have a similar problem.

    I have one sites with the plug-in installed where it works just fine.

    But on a different site, it did work, but now it doesn’t?

    It still imports in manual mode. And yes my Cron job is working just fine.
    I tried resetting the plug-in without any success with the help of that debug app.

    Any ideas?

    Justin, FYI I don’t have a wp-content/mu-plugins folder in my wordpress install. Were you suggesting I create one? I can also install your debug plugin.

    I figured an easy way to get importing working again was to delete the plug in and reconfigure. But like others have reported, I can’t delete the plugin. I can delete the files, but when I reinstall, all of the database info and config is still there.

    Any hints on deleting?

    I’ve set mine to check once a day and auto import has never worked for me. CRON is working fine, the site gets 400 – 600 visits a day.

    @jtsternberg Can we set up a server based cron to run this?

    @wmodes – Yes, you can create a mu-plugins folder. These are meant as ‘must use’ plugins. I wouldn’t want to have WP_DEBUG set to TRUE for very long on a production site though. Also set define( 'WP_DEBUG_DISPLAY', false ); to prevent errors and warnings from displaying on the front end.

    I’m going to run this myself and see what comes up.

    Minor update on this… Just noticed I had the ‘Auto-import future photos:’ unchecked. I’ve checked it and we’ll see what happens next…

    Major update: Checking that box does the trick. It’s now auto-importing for me. Sorry for taking over this thread @wmodes.

    Plugin Author Justin Sternberg

    (@jtsternberg)

    @wmodes Is that potentially the solution to your problem as well?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Automatic import not automatically importing’ is closed to new replies.