WordPress.org

Support

Support » How-To and Troubleshooting » Automatic image url linking — how to disable?

Automatic image url linking — how to disable?

  • Regarding the Link URL field in the image editing page:

    I recently upgrading to 2.9.2 and to my dismay discovered that all subsequent images I uploaded in posts were automatically linked as attachments and therefore clickable in the posts. Although I noticed this new field it took be a while to realize the problems related to it.

    How can I disable this feature or make it default to NONE? I never want my images to be clickable. I want this field to always be empty.

    Having all the images clickable wreaks havoc with plugins like “Where did they go from here” – each time someone clicks on an image, the current page is added to the list so you end up with a referral list of all the same page (the one you are already at).

    Also, I noticed today that if I “Cancel” out of the image editing page I can no longer edit any of the existing images in the post. Oh well, that’s a subject for another day, I guess.

Viewing 1 replies (of 1 total)
  • esmi

    @esmi

    Forum Moderator

    Set it it to “None” and it will keep that setting until you change it again.

Viewing 1 replies (of 1 total)
  • The topic ‘Automatic image url linking — how to disable?’ is closed to new replies.
Skip to toolbar