Support » Fixing WordPress » Automatic Facebook Posts Posting Old URL

  • Agrajag27

    (@agrajag27)


    I have Jetpack set up to share any new post I put up on my Facebook page. It’s worked pretty much fine all along. Then, last month, I moved the blog to a new domain name and changed every reference I could find. Everywhere I look I see nothing but the new domain name EXCEPT when I create a new post and it shows up on Facebook. It insists on showing the original domain name. I redirect it so the link still works but I’d like to find this reference and kill it. The settings for Sharing I turned off and re-established (just in case). No difference.

    Where is that domain name still being held and how can I change it?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Andrew Bartel

    (@andrew-bartel)

    I’m sure there’s still an entry somewhere that has the old site name. Try using this script: http://interconnectit.com/products/search-and-replace-for-wordpress-databases/ to run a find a replace.

    Be very careful, this thing is powerful and doesn’t have an undo button. Make a backup first and delete the thing when you’re done!

    Agrajag27

    (@agrajag27)

    Nope. Ran it (thanks) and it found 9 instances. It changed them all so I put up another quick post and the old URL is still there. Either Jetpack is storing this info somewhere else or Facebook is.

    Andrew Bartel

    (@andrew-bartel)

    Did you register an app with facebook? Perhaps the old url is there.

    Agrajag27

    (@agrajag27)

    Not that I’m aware of. I certainly haven’t created any apps. Very frustrating.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Automatic Facebook Posts Posting Old URL’ is closed to new replies.