Support » Plugin: WPScan - WordPress Security Scanner » Automated scanning not working

  • Resolved Erik Molenaar

    (@erikmolenaar)


    Hi,

    I am on plugin version 1.13.2 and while the automated scanning function used to work in the past, it currently does not do any automated scans jobs anymore.

    Doing a manual scan by hitting the “Run all” button works fine.

    I have a functioning cron and no PHP errors on my website.

    Which cron jobs are created by your plugin for these automated scans? This way I can do some troubleshooting finding the cause?

    Looking forward to your reply. Thanks.

    Kind regards
    Erik

    Screenshot:

    12.11.2020-10.20.36

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author ethicalhack3r

    (@ethicalhack3r)

    Hi Erik,

    We’ve had another user report this, and they had the twice daily setting too.

    I couldn’t reproduce the issue though last time I looked into it.

    I’m going to spend some more time looking into it.

    Thanks,
    Ryan

    Plugin Author ethicalhack3r

    (@ethicalhack3r)

    Does your summary panel show the next scheduled scan date/time?

    If you install the WP Control plugin, does it show a scheduled cron job?

    My screenshots:

    https://imgur.com/a/8Q5koDb

    Thread Starter Erik Molenaar

    (@erikmolenaar)

    Hi,

    No it does not show the next scheduled scan date/time (Twice daily is activated according to the settings). I also don’t have that scheduled cron hook, not any other containing ‘wpscan’.

    12.13.2020-14.17.11

    Looking forward to your findings and fix. Please let me know if I can do anything to be of assistance.

    Plugin Author ethicalhack3r

    (@ethicalhack3r)

    Hi Erik,

    I have been monitoring the automated twice daily scanning in our test environment since Friday and haven’t been able to reproduce the issue yet 🙁

    Could you try two things for me, please?

    1. Are you able to re-schedule new automated scans?

    2. If not, can you deactivate then reactivate the plugin, can you now?

    Thanks,
    Ryan

    Thread Starter Erik Molenaar

    (@erikmolenaar)

    Hi @ethicalhack3r

    I tried both, but with no result.

    I can set up a development server for you to tinker if you like? If so please contact me on info AT erikmolenaar.nl

    Thanks for your help 🙂

    Thread Starter Erik Molenaar

    (@erikmolenaar)

    Hi @ethicalhack3r

    Any update yet?

    Looking forward hearing from you. Thanks.

    Plugin Author ethicalhack3r

    (@ethicalhack3r)

    Hi Erik,

    We have fixed the issue in our development environment and will be releasing the fix along with many other small improvements, and new features, in January. Aiming for the week of the 11th January.

    For now, you should be able to schedule an automated scan, as long as it is not exactly the same as your previous one. Use a slightly different time for example.

    The bug happens when you deactivate the plugin, some values from the database are not cleared, which doesn’t allow WordPress to save news ones, if they are the same.

    Thanks,
    Ryan

    Thread Starter Erik Molenaar

    (@erikmolenaar)

    Hi Ryan,

    I tried your suggested fix by setting a different time, but it does not work.

    – At the “Summary” widget at “Report” it does not show the next scan time.
    – And I also can’t see any crons being added added to execute the scheduled scan.

    If you like to me to set up a staging site to demonstrate the bug, please let me know.

    Thanks,
    Erik

    Plugin Author ethicalhack3r

    (@ethicalhack3r)

    Hi,

    That’s strange. If you have the wpscan_scanning_time and wpscan_scanning_interval options in the database, if you delete them, are you able to schedule a scan then?

    Yea, a stanging env would be great, thanks.

    I think the issue will be resolved by deleting the above options from the database. This will be fixed in the next version.

    Thanks,
    Ryan

    Plugin Author ethicalhack3r

    (@ethicalhack3r)

    This should be fixed in the latest version, 1.14 🙂

    Thread Starter Erik Molenaar

    (@erikmolenaar)

    Hi @ethicalhack3r

    I updated to 1.14.1 but now the scheduled scanning settings “Automated Scanning” and “Scanning time” completely disappeared. I suspect it is due to the following:

    I am also getting this permanent warning nag:

    01.10.2021-23.01.37

    Like many other WordPress sites, I indeed set DISABLE_WP_CRON to true to disable the virtual WP cron and set up a real cron job. For many sites, this is the recommended setup so nothing fancy 🙂

    Can you please bring back the settings part if this constant is applied and remove this permanent nag? Thanks.

    Kind regards
    Erik

    Plugin Author ethicalhack3r

    (@ethicalhack3r)

    Thanks for letting us know Erik, we’ll get that fixed today.

    Plugin Author ethicalhack3r

    (@ethicalhack3r)

    This should be fixed in version 1.14.2 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.