WordPress.org

Forums

Meta Slider
[resolved] Autoload visibillity conflict (3 posts)

  1. artisticphoenix
    Member
    Posted 11 months ago #

    Hi, the private visibility "scope" of the method MetaSliderPlugin::autoload(), conflicts with other external libraries, such as in my case Doctrine ORM. Changing this to public fixed the issue but just thought I would mention it. I have a highly customized site, which I'm sure isn't the norm but none the less it seems that an autoload method should have a public scope.

    Here is the specific error.
    Fatal error: Call to private method MetaSliderPlugin::autoload() from context 'Doctrine\Common\ClassLoader'

    https://wordpress.org/plugins/ml-slider/

  2. Matcha Labs
    Member
    Plugin Author

    Posted 11 months ago #

    Hi artisticphoenix,

    Thanks for reporting this.

    I've updated this in trunk (https://plugins.trac.wordpress.org/changeset/905576) so if you want to change your local copy you can be confident it'll still work when I release 2.8.1.

    Regards,
    Tom.

  3. artisticphoenix
    Member
    Posted 11 months ago #

    Thanks for the quick fix

Reply

You must log in to post.

About this Plugin

  • Meta Slider
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.