Support » Plugin: Search by Algolia – Instant & Relevant results » Autocomplete only showing for administrator

  • I have noticed that autocomplete is only working when the visitor is logged into WP. Is this normal behavior or a setting that I am overlooking?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor rayrutjes

    (@rayrutjes)

    Hi there,

    I think it might be related to the caching plugin you are using.

    What plugin are you using for caching?

    Best,

    Thanks for your reply. We do not have a cache plugin installed or activated.

    Judging from your reply, algoia for woocommerce’s autocomplete should be active for all visitors regardless of if they are logged into wp or not. Knowing this, I think I can troubleshoot on my own for a bit.

    Thanks.

    Plugin Contributor rayrutjes

    (@rayrutjes)

    Indeed, the autocomplete should be active regardless of the user session.

    Let me know if you need help.

    Do you have any error in the console? Maybe a live example?

    Best,

    Plugin Contributor rayrutjes

    (@rayrutjes)

    Did you manage to solve your issue? I’m very curious about the solution.

    Hi, Not sure if this relates to this topic but my search results are intermittent? In the settings we have set to show 5 business listings and 3 listing categories. Here is our website – https://www.meandmymates.com/sale/ and we are using this theme – https://themeforest.net/item/listify-wordpress-directory-theme/9602611 for our website which is a business directory. Our autocomplete shows custom post type results in the. However, if I visit one of the page results in the drop down, when we go back to search for that term again, the result is missing. It also seems to only show the 5 most recent businesses no matter what we type in the search box. If you type “trading” in the search bar, it should show this page – https://www.meandmymates.com/sale/listing/trading-places/ in the results but it doesn’t. We are using SiteGround as a host with their caching plugin.

    Any ideas?
    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Autocomplete only showing for administrator’ is closed to new replies.