Support » Plugin: Search with Typesense » Autocomplete enhancements

  • Resolved sannin

    (@sannin)


    Hey again,

    I just started using the autocomplete feature, and i have a couple of suggestions.

    – There should be a way to modify the query to typesense. You have done it to some extent to instant search shortcode with the query by parameter. I think that a filter that offers full control over the query should be better.

    In my case, i am missing some important features such as search in SKU fields, EAN etc. After that i would like to take advantage the features of typesense, such weightened search.

    – Pressing enter should redirect search page. Also a “See more results” link would be nice at the end of the results by default, but it can already be done by overriding the template.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor digamberpradhan

    (@digamberpradhan)

    Hi @sannin ,

    Thanks for your feedback. We’ve added query_by as a shortcode parameter for autocomplete shortcode so [cm_typesense_autocomplete query_by="post_tile,post_content"] you can change the query by parameter.

    As for weighted search – it’s a bit more difficult to apply, we are seeing what we can do about it. For other enhancements please do specify what you’re looking for – there is a lot that can be done with typesense and we plan to gradually add more features and user feedback is invaluable to us.

    Thread Starter sannin

    (@sannin)

    It is the first time i have seen integration of a new feature within an hour of the request! I am speechless, you guys rock!

    I tried the query_by argument, it works with the default post collection but it doesn’t work with my custom product collection. When i use “query_by” with the product collection it does not fetch results any more.

    Plugin Contributor digamberpradhan

    (@digamberpradhan)

    Firstly thank you 😀

    Secondly – are the fields you’ve selected in the schema for the document post_type ? I’ve checked with three post types enabled at once and i am getting results for all 3.

    Can you check console – it may throw a no field in schema type error.
    You are probably getting a 404 not found on those.

    You can see in my screenshot for the console. I get a 404 error when viewing ajax request. the response is post_parent field not found.

    Thread Starter sannin

    (@sannin)

    It works fine for me too now, maybe some caching issue, i am not sure!

    There are something i have in mind, i will study the typesense api some more and get back to you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Autocomplete enhancements’ is closed to new replies.