Support » Plugin: Search with Typesense » Autocomplete doesn’t work

  • Resolved sannin

    (@sannin)


    Hey,

    Autocomplete shortcode doesn’t work at all.

    The placeholder div exists in the page, the index.js is loaded with no error, but no search input field appears:

    <div class="cm-autocomplete" data-placeholder="Search for..."></div>

    I have posts and products indexed. Instant search shortcode works correctly, so it is not an indexing issue.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor digamberpradhan

    (@digamberpradhan)

    Hi @sannin ,
    The link you provided doesn’t seem to have either instant search or autocomplete showing. Please see here: https://tinyurl.com/y6w4cvyg

    My guess is caching of the page may be preventing the loading or execution of js.
    Can you please try temporarily turning off your cache.

    Thread Starter sannin

    (@sannin)

    Yes that is the problem, the shortcode exists but autocomplete does not. Caching should not be an issue for that page, i had disabled optimization for all typesense assets as well, but just in case i disabled it completely.

    You can see that all typesense js and css files load correctly and i dont have any console log errors.

    https://imgur.com/a/tVttfbw

    Plugin Contributor digamberpradhan

    (@digamberpradhan)

    Hi @sannin ,

    It took me a while to figure out the issue. I have patched the issue and the issue should be resolved with version 1.1.8

    Thread Starter sannin

    (@sannin)

    I can confirm the patch has fixed the issue, thanks a lot!

    • This reply was modified 1 year ago by sannin. Reason: Typo
    Plugin Contributor digamberpradhan

    (@digamberpradhan)

    Great to know,
    Thanks for bringing this to our attention.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Autocomplete doesn’t work’ is closed to new replies.