Support » Fixing WordPress » Auto Upgrade/Update on Mac OS X?

  • Hi,

    my apache, php, mysql & wordpress installations run on my very own, local Mac mini (Snow Leopard) at home.
    I want to use WordPress’s auto update feature but I don’t know how to configure my Mac to make it happen.
    What I uderstood so far is: an ftp or (preferably) sftp server must be running on my Mac, right?
    Well, OS X comes with ssh/sftp support and I activated it.
    However, the users that can log in via sftp are the normal users that can log into the Mac locally as well. They have their homes in /Users.
    So is this out-of-the-box sftp server usable for the WordPress auto update feature? If so, how would I configure it to make it work? I guess the default directory after logging in via sftp shouldn’t be /Users/myhome but somewhere inside the WordPress installation path, right?

    Or is OS X’s sftp server a dead end here and I have to install another sftp server with its own (just sftp) user and its own home folder? And what server would that be? And how would I configure that one?

    I’m sure there’s already at least ONE ressource on the web (a blog article, a howto, …) where those questions are covered. However, I wasn’t lucky with Google or a forum search here. 🙁

    So if anybody could point me in the right direction that’ll be SO great!

    Thanks a lot,

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’m having the same issue.

    It’s permissions. I had the same issue, then found this on

    Hope this helps you too.

    Set file permissions

    On Mac OS X (Leopard), the Apache HTTP Server runs under the user account, _www which belongs to the group _www. To allow WordPress to configure wp-config.php during installation, update files during upgrades, and update the .htaccess file for pretty permalinks, give the server write permission on the files.

    One way to do this is to change the owner of the wordpress directory and its contents to _www. Keep the group as staff, a group to which your user account belongs and give write permissions to the group.

    $ cd /<wherever>/Sites/<thesite>
    $ sudo chown -R _www wordpress
    $ sudo chmod -R g+w wordpress

    This way, the WordPress directories have a permission level of 775 and files have a permission level of 664. No file nor directory is world-writeable.



    I found this to be the most helpful in overcoming this issue:

    However, after doing the chown to the directory (changing owner to www) I still got the connection error page asking for connection info (host, user, pw and type)

    I noticed that these fields were showing up auto filled because I had attempted to do this previously. I felt that this information in the database was causing my problem even though I had successfully changed the permissions of the wordpress directory.

    I went into the WP database and under the wp_options table near the end I found an entry called “ftp_credentials”. I deleted that, but I also re-chowned the directory after doing that. But after both those things, I was able to do the upgrades without a problem.



    Lucky you …

    I haven’t had any luck, yet.

    I’m using the XAMPP package on my Mac mini which brings Apache, MySQL and PHP.
    I don’t use Apple’s Apache/PHP and I didn’t download MySQL from their site.

    In this XAMPP package Apache (process name is ‘httpd’ for those who didn’t know) runs under the username ‘nobody’.

    So I chown’ed all files & folders in my wordpress installation directory recursively to ‘nobody’ but to no avail. I still get the ftp/sftp credentials dialog when I try to (auto-)install a theme in this case. (I guess it’s the same for auto-installing/-updating plugins or wordpress itself, right?)

    Changing the files’ permissions to make them writable for the group (‘sudo chmod -R g+w *’ in the wordpress directory) didn’t help either. The user ‘nobody’ belongs to the group ‘admin’ here on my system.

    So I have to look deeper into this. Maybe it’s something with groups…



    Problem solved! 🙂

    Comment #44 under this blog post brought the solution for me:

    Followed the instructions and couldn’t believe my eyes when installing a theme out of wordpress worked finally! No ftp credentials dialog appeared! 🙂

    So, thanks, pinkfrankenstein, for pointing me to this article! 🙂

    Will test it for plugins and wordpress updates, too.

    maybe someone can help me now that the problem has been solved

    i really dont understand a lot of this language.. im using snow leopard with xampp and trying to set the permissions.
    however, i dont understand if im supposed to be working in the files under the xampp application folder or somewhere else?

    esentially, this doesnt make sense to me:

    To set up file ownership correctly:
    In WP root directory
    chown -R yourusername:apachegroupname *
    In my case…
    chown -R johan:apache *

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Auto Upgrade/Update on Mac OS X?’ is closed to new replies.