Support » Installing WordPress » Auto upgraded to 3.1.1 Now I can't upload images / media to posts

Viewing 14 replies - 1 through 14 (of 14 total)
  • Have you tried to upload by clicking on Media.

    Hi

    Thanks for the tip, I can load the image via the media library link.

    I have to load it and save it and open it again to get the img url. Once I have that I can copy it into the blog, using HTML tags.

    This works, but its not ideal. I can’t load the image files from the posts or pages.

    I’ve also noticed that I only have the HTML view of the pages. The “Visual” view seems to show the HTML view as well now.

    Try – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    I’m getting this as well. What hosting company are you with? I’m with Dreamhost on a VPS. The latest they told me is that my WordPress install is using a crazy huge amount of CPU and that the upload process (for a 225kb file) is spiking over our limit and therefore being stopped. Somehow that sounds a bit wacky to me.

    I’m wondering if the “hardening of security measures in the media uploader” has done something which causes problems on with some hosts?

    Oh – I should say: I can’t upload from anywhere – post, media page, etc.

    Same problem, no idea to resolve it.

    New install has been done, nothing has changed…

    Update to this post. I have tried the following:

    1. Completely deleted all WordPress files and re-uploaded from a fresh download from WordPress.org
    2. Added mod_security permissions in htaccess
    3. Disabled mod_security on the server
    4. Changed htaccess to be just the native htaccess code that comes with WordPress
    5. Double checked all folder permissions
    6. Uploaded different files to see if it’s related to my test file (all file sizes below 1MB)
    7. Attempted upload from both the post interface and from the media area
    8. Attempted to upload using both Flash and standard browser buttons. Neither work. Flash returns an HTTP error (no other info) and the standard browser upload button returns an “internal server error”
    9. Begged the Gods for help

    No joy on any front.

    Checking the error logs, I receive the following (IP address and hostname hidden for security):
    [Thu Apr 14 13:11:46 2011] [error] [client 555.555.555.555] ModSecurity: Input filter: Failed writing 8192 bytes to temporary file (rc 18446744073709551615). [hostname "hostname.com"] [uri "/corporate/wp-admin/async-upload.php"] [unique_id "TadVAa3s33IAAGmoDMgAAAAA"]

    So questions that I have:

    • How much CPU usage should uploading a 500kb file take?
    • Is there anything in the WordPress 3.1.1 media uploader revisions that would create this type of error?
    • What are possible causes for failures to write a temporary file?
    • Is there anything else I can try or any other diagnostic I can use to get a better idea of where this whole system is breaking down?

    Thanks in advance,

    –eric

    I still haven’t found a resolution …. I am a bit nervous about doing a complete reinstall, but I see that you guys have tried it and still no joy.

    I’ve also noticed that I cant schedule posts (without media) either…

    Any way to get a download to do a fresh install of the previous version of wp??

    Upgrade to a previous version (arf! ) seems to be the only way (2.9)

    Today Dreamhost fixed the issue. Turns out that there was a large file in my tmp directory (which PHP uses to handle the uploads) that was using up 100% of the capacity and therefore other uploads failed. The trick is that the tmp directory is outside the available folder structure for most shared hosting accounts, so Dreamhost needed to empty out the folder by hand. Once they did that, the uploader seems to be working like a charm!

    So bottom line: try contacting your hosting company and having them clean out the contents of the tmp folder that PHP uses for uploading.

    As a side note, I wonder if there was anything in the updating process that could have created that huge file, because none of our users tried to upload a huge file…

    I have this issue too, and my hosting company, hostclear, who I must say are great, are a bit baffled. I have a workaround with a plugin, Add From Server. You can manually FTP the media and then add it from WP. Its doing things twice I know, but it is better than a kick in the subdomains 🙂

    Same problem with me as well on my site. So the best solution I see here is to go back to 2.9?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Auto upgraded to 3.1.1 Now I can't upload images / media to posts’ is closed to new replies.