Support » Fixing WordPress » auto upgrade to 3.6.1 fails

  • Resolved staciquigley


    I have been unable to update my 3.5.2 install of WordPress. I contacted my web host and they have referred me here. Domain is

    Any ideas why the auto updates no longer work? It has worked flawlessly before now.

    Here is error message that displays:

    Downloading update from…

    Warning: touch() [function.touch]: Unable to create file /tmp/wordpress-3.tmp because No such file or directory in /home/profou8/public_html/wp-admin/includes/file.php on line 179

    Warning: unlink(/tmp/wordpress-3.tmp) [function.unlink]: Operation not permitted in /home/profou8/public_html/wp-admin/includes/file.php on line 503
    Download failed.: Could not open handle for fopen() to /tmp/wordpress-3.tmp

    Installation Failed

Viewing 7 replies - 1 through 7 (of 7 total)
  • Have you tried it with all plugins deactivated?

    Thank you for the suggestion – I will try anything! Unfortunately, I did disable all plugins and still received the same error messages.


    This error message is about not being able to write or open a file in “/tmp” when upgrading WordPress. Please try the following:

    1) Make sure that ‘wp-include’ and ‘wp-content’ directory set to 755 permission.

    2)Add this line to the bottom of your “wp-config.php” file:


    This line will result in WordPress using your “/wp-content/uploads” folder to store temporary files required during the upgrade process instead of the system-wide /tmp folder.


    Thank you Anshu! I must admit that I didn’t know how to do this, but when I contacted my web host this time and sent your instructions they had the update done within minutes.

    I only hope I will be able to do the auto updates again in the future. I am very comfortable in the WordPress dashboard, but the coding is something I need to learn. The tech support at my web host said I may need to change a setting in my wp-admin page, so we’ll see what happens when the next update is released.

    Thank you again for taking the time to help me!


    I struggled with this update fail for two weeks now but solved it.
    People who using direct admin upgrade from you direct admin panel!

    Maybe it works for cpanel Too.
    the original install i also did trough direct admin maybe thats connected somehow to the issue?


    like magic!! thanks anshu

    Thanks Anshu! Worked for me as well!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘auto upgrade to 3.6.1 fails’ is closed to new replies.