Support » Installing WordPress » Auto upgrade to 2.7.1 doesnt finish.

  • I used the auto upgrade, the page got to the point where it says installing wordpress but after 10 minutes was still the same. Trying to go to the site or wp-admin just shows:

    Briefly unavailable for scheduled maintenance. Check back in a minute.

Viewing 14 replies - 1 through 14 (of 14 total)
  • delete the
    .maintenance
    file in your wordpress root and see if it did upgrade or not

    The same happened to me. I looked into the root directory and noticed a file with the name .maintenance and simply renamed it. It made the blog to come back. The auto upgrade does not seem to be deleting that file. It may have to do with the directory permissions. But, FTP to the site and rename the file I mentioned above. It may take care of your problem too.

    I had exactly the same problem, waited for 10 min., repeated, waited for 20 min. After performing a manual update after that, I had the new version 2.7.1, but the message “update not finshed, please repeat” (or so) still showed up. The dashboard itself indicated the new version 2.7.1 though.

    My questions in the German forum were not answered sufficiently. After reading your hint and erasing .maintenance, everything seems fine.

    I wonder how such an error can occur, because I did not do anything wrong, the rights in my webspace are / and everything else is / totally usual. One does not trust any option “auto upgrade” any longer after this.

    Similar problem for me, too, with the 2.7.0 > 2.7.1 upgrade. I had to wait about 10 minutes before the upgrade said it completed successfully and in the interim saw the message: “Briefly unavailable for scheduled maintenance. Check back in a minute.”

    When the upgrade completed, with several warning messages, I saw a new message that the update had not completed and to repeat the update. I tried repeating the auto-update, but it said that the update was already successfully installed and to try a manual install.

    After reading this post, I ftp’d to my blog site, looked for the “.maintenance” file mention by the Moderator’s post and deleted it. All seems back to normal and the warning message to reinstall the update is gone.

    I had the same issue. I renamed the .maintenance file and tried again. The second time the upgrade sailed through without any problems or wait.

    Strange.

    Alex

    To get back to this, after a while WordPress came back automatically and said there was a problem with the update and that I should run it again. I did and it worked perfectly the second time. It was probably a hiccup on my server end as it is a rather cheap host.

    Great feature!

    Same here.

    I’d like to just pitch in and say that, in spite of the failure to remove that .maintenance file, which appears to be causing the issue in most cases, this built-in automatic upgrade, simply, rocks.

    The .maintenance file is removed, at the end of the upgrade process. So, if yours is still there, then the upgrade did not complete fully.

    That may depend on servers, Otto, as you probably know. Perhaps a permissions issue prevents it in some cases on those servers. I know it’s meant to be deleted and the devs didn’t forget about it; can’t always account for all server quirks.

    Like said, great job 🙂

    Hi:

    I attempted to upgrade 2.7 to 2.7.1 and received the following error message: Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1853087 bytes) in /var/www/vhosts/myblogurl.com/httpdocs/wp-test2.7/wp-includes/http.php on line 1032

    Do you have any suggestions?

    Thanks,
    Fred

    Off-topic, Fred, but see here for some workarounds. This is a server-side memory issue, probably have too many scripts running, consuming too much memory, or possibly a memory leak somewhere.

    My upgrade process seems to be stuck at the “Unpacking the core update” step. I used filezilla to look for the .maintenance file; however, I don’t see it? Any recommendations?

    I removed the previous plugin 1.2 or something like that, and the update process proceeded further. Now I have an “Installation Failed” message?

    Got same issues as frioman on ALL plugins – both during upgrade and during new install … and I’m on WP 2.8.4

    That said, it is only one of my many sites that are suffering this – but still completely beaten by it.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Auto upgrade to 2.7.1 doesnt finish.’ is closed to new replies.