[resolved] Auto-upgrade from 3.0 to 3.0.1 Failed (9 posts)

  1. evanlong
    Posted 5 years ago #

    An auto-upgrade from 2.9.2 to 3.0 worked fine but auto-upgrade attempts to 3.0.1 from there give only the message, "Downloading update from http://wordpress.org/wordpress-3.0.1.zip…" and nothing else.

    I've also attempted a manual update via the short instructions, copying all the files from the unzipped folder onto the site, and upon returning to the dashboard, it tells me that I am still running 3.0.

    3.0 has given me a lot of problems and I want to upgrade. What is missing?

  2. There's still a few more steps after uploading the 3.0.1 files.


    See "Manual Update."

  3. evanlong
    Posted 5 years ago #

    I read those instructions. What are you referring to specifically?

  4. evanlong
    Posted 5 years ago #

    "Step 1: Replace WordPress files"


    "Step 1.5: Remove .maintenance file"

    Not applicable.

    "Step 2: Update your installation [...] Visit your main WordPress admin page at /wp-admin. [...] If a database upgrade is necessary at this point, WordPress will detect it and give you a link to a URL like http://example.com/wordpress/wp-admin/upgrade.php."

    Not applicable according to dashboard (see original post).

  5. evanlong
    Posted 5 years ago #

    I even tried typing in the "upgrade.php" link manually out of curiosity and it returned, "No Upgrade Required - Your WordPress database is already up-to-date."

  6. Try running the upgrade.php file anyway (even though the Dashboard doesn't indicate it).

    Nevermind. Just saw your latest reply.

  7. The only thing I can think of Step 1, sub-step 3.

    Delete the old wp-includes and wp-admin directories on your web host (through your FTP or shell access).

    After that, reupload the files for 3.0.1.

  8. evanlong
    Posted 5 years ago #

    It was a server memory problem. The hosting company raised a memory limit (the auto-upgrade used too much memory so it wouldn't work) and the auto-upgrade went through.

  9. I'm sorry I couldn't help, but I'm glad you and your hosting company fixed the problem. :)

Topic Closed

This topic has been closed to new replies.

About this Topic