Support » Fixing WordPress » Auto upgrade from 2.7 to 2.7.1 doesn’t work

  • I tried using the Automatic upgrade in WP 2.7 to upgrade to 2.7.1 using the Safari and Firefox web browsers on Mac OS X 10.5.6 (I am using 1and1.com as a web hosting service – linux shared server). What happens when I click on the Automatic Upgrade link is the message:
    “Downloading update from http://wordpress.org/wordpress-2.7.1.zip

    Then the page just sits there (no spinning or any type of icon indicating anything is happening and the web browser page status says ‘done’). I tried in Safari and Firefox with the same result. Anybody with ideas what is happening? Thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • from http://codex.wordpress.org/Core_Update_Host_Compatibility

    problems and solution for 1and1
    (fails running PHP 4, but works with PHP 5. Add AddType x-mapp-php5 .php to .htaccess to enable PHP 5. This also appears to not only affect Core updates but some Plugin updates as well.)

    Translation: Add this line
    AddType x-mapp-php5 .php
    into your .htaccess file, which is in the top folder of your WordPress install

    Mmm, had the same problem, tried this solution, got a page full of interesting gibberish and a broken blog. Now trying to manually go back to 2.7. Sigh.

    Leoni – you might contact 1 & 1 for some help

    Oops, sorry, no I’m not on 1 & 1 … I’m at vodahost … they don’t offer support for wordpress installations, so I have to muddle through on my own 🙂 That’s ok, I’m taking this opportunity to have a fresh start, lol.

    That fix was specifically for 1 & 1, not necessarily any other host. Sorry

    This is all what`s happening

    Downloading update from http://wordpress.org/wordpress-2.7.1.zip

    Unpacking the core update

    This cured the issue with my install on 1and1. Thanks for the info!!

    The auto-update kept failing for me too on asmallorange.com. I ended up doing a manual upgrade.

    Thank you very much ‘stvwlf’! I added the line to the .htaccess file and the auto upgrade feature worked. Greatly appreciate it!

    Not working for me as well…
    I had an auto-upgrade plugin that worked just fine. Now, the feature is part of Word Press proper… and it doesn’t work. That was a nice upgrade. Great job testing :-\
    So, is there a workaround? My provider does not allow me to muck around with .htaccess.
    Is this fixed in 2.7.1? Or will I be running into this everytime there is an upgrade?

    Found a thread that suggested deactivating the auto-update-plugin and upgrade went smoothly 🙂

    I am on 1&1 and have deactivated the Automatic Upgrade plugin. I also checked and am running PHP 5.1.6 on my server. Is this .htaccess hack still necessary?

    If so, exactly where in the .htaccess file should I insert that line? (there is a ‘#BEGIN wordpress’ and ‘#END wordpress’ included in the file).

    Thanks for any help!

    Bump…

    # BEGIN WordPress
    AddType x-mapp-php5 .php
    # END WordPress

    and it will work

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Auto upgrade from 2.7 to 2.7.1 doesn’t work’ is closed to new replies.