[resolved] Auto upgrade failed because of PHP - now locked out (2 posts)

  1. Hoib
    Posted 5 years ago #

    I have a WP blog up on the internet. It works.
    I wanted to play a bit with some new thoughts so I broght down a complete copy to my local system, so I'm not playing with the working live version. I thought I was soooo smart... I'm on Win XP Pro, AMD 3.1 proc, 2 gb RAM, large disk is 1/2 full. Nothing too fancy.

    I fired the local copy up. Went into my Dashboard. At the top, it beckoned me to auto-upgrade. I obliged. It went through 5 steps and at the final one I see: "Your server is running PHP version 5.1.6 but WordPress 3.2.1 requires at least 5.2.4." I can go no further. I certainly didn't run any server, or PHP services, just called index.html up in IE7 but... I downloaded and installed WAMP 2.1 because that advertised it had PHP vers 5.3.5. Tried the Dashboard - same result. Rebooted. Tried the Dashboard - same result. Uninstalled and resinstalled WAMP 2.1 - rebooting each time. Tried the Dashboard - same result. It has it buried somewhere that I used PHP 5.1.6 and won't continue. I can't' figure out where PHP vers 5.1.6 came from or where it's installed. I doesn't show in your Add/Remove applet (of course). You cannot uninstall it normally - I was sure the new version would simply overlay it. Wrong!

    I had saved the downloaded website seperately in another folder and was using a copy of it. OK, I'll just go back to my all original fileset from the download an hour ago and start over. You guessed it!

    So I am completely stumped. I do not know how or where or what file to modify or what registry entries I have to hit in order to bypass this error and get the Dashboard to show.

    I shouldn't have done what I did, OK I'll take my beating. Please! How do I recover from this fiasco???



  2. Hoib
    Posted 5 years ago #

    Issue is resolved.

    I inadvertently and unintentionally wound up "logging in" to the live copy even though I was editting in the local copy. The new version requires the PHP upgrade which the live server does not have. I have no ability to upgrade PHP as it's not my server. The error is in fact coming from the server, not my local in-house copy as I intended. And, I never realized it until just now.

    This fix will have to wait for the server owner to take action.


Topic Closed

This topic has been closed to new replies.

About this Topic