Support » How-To and Troubleshooting » Auto upgrade failed 2.8.3 to 2.8.4

Auto upgrade failed 2.8.3 to 2.8.4

  • Could not copy file:

    I did an auto update a few days ago to 2.8.3 and all went well.

    What do I need to do to get this auto update to work?

    Should I manually upload just that file?

    I have followed these directions:
    I have backed up my database, wp-config.php, .htaccess, the wp-content folder (with all my theme changes).
    plus a mirror on cpanel of the whole wp folder

    My current install of 2.8.3 is working fine.

    any help??


Viewing 8 replies - 1 through 8 (of 8 total)
  • Some one on the forums mentioned:
    changing permissions on that file to 777
    and also deleting the previous upgrade folder (said 2.8.3).

    When they mention changing permissions, is this the file in the root of the install or the same file in the wp-content/upgrade/wp directory?
    Should I delete the 2.8.3 upgrade folder? As that version is running at this time I hesitate to do that.

    any help?

    Ok, tried this changing permissions on that file to 777..
    didn’t work.
    Still get :
    Could not copy file:

    installation failed.

    How frustrating.

    Can someone who has had this issue and resolved it please respond?


    A solution to a failed automatic upgrade is to manually upgrade instead: http://codex.wordpress.org/Upgrading_WordPress_Extended

    Upgrade manually, and it’s not just the one file.

    See the instructions here.

    Ninja edit, or do as iridiax suggested… 😉

    Well I was really trying to avoid manually uploading everything all over again. But thanks any way.


    All you need to do is rename the folder upgrade to ‘upgrade1’ (or remove) and then rerun the upgrade automatically link.
    WP will recreate the upgrade folder and proceed. (wp-content/upgrade)

    Wonder why this info isn’t included in the auto update how to list along with back up your database, etc?
    Would of saved me and lots of others precious time.

    thanks.. she does a happy dance!

    renaming the wp-content/upgrade to something else worked for me as well.

    Thanks for sharing!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Auto upgrade failed 2.8.3 to 2.8.4’ is closed to new replies.