Support » Plugin: WP-SpamShield » Auto updated and broke MANY sites

  • Resolved Starhorsepax2

    (@starhorsepax2)


    We are using this on many client sites and MULTIPLE sites just blew up. Not all of them but a LOT. They are not all on the same version of wordpress, some are on 4.6.2 some are on 4.7.1. They have different plugins and themes so it is not a consistent plugin or theme conflict. The only thing they have in common is Wordfence but that is also on our sites that did NOT break.

    WPSS_Utils::is_plugin_active() in /home (left off for security) /wp-content/plugins/wp-spamshield/includes/class.utils.php on line 179 is in the error logs of EVERY ONE.

    I was not aware this auto updated but this auto update version is not compatible on many sites based ton the readme.txt.

    We are deleting the plugin folder and restored sites but this leaves us without spam protection. PLEASE UNDO whatever you did! Or at least tell me how to block auto update so I can roll back.

Viewing 11 replies - 1 through 11 (of 11 total)
  • wellbeingtips

    (@wellbeingtips)

    I got this error but on website with not updated newest version: current version is 1.9.9.8.2
    error log: [18-Jan-2017 18:42:15 UTC] PHP Fatal error: Call to undefined method WPSS_Utils::is_plugin_active() in /home/quotfeed/public_html/wp-content/plugins/wp-spamshield/includes/class.utils.php on line 179

    beachdog

    (@beachdog)

    I have the same error as Anty and about 45 sites showing white screens. This is urgent! Also, I am blocked from ftp login with the error “Status: Check your login credentials. The entered username starts or ends with a space character.” (I typed it several times; there is no space character).

    Starhorsepax2

    (@starhorsepax2)

    Did you notice the ‘latest version’ was just added? 1.9.9.8.3 was released today right AFTER that 1.9.9.8.2 – someone seems to have noticed they caused Chaos. The error line on all of mine referenced that Wordfence plugin. But why it didn’t break ALL the sites I cannot imagine. (It’s also an all new file in Spamshield, I compared to the old one.)

    Plugin Contributor Red Sand Media Group

    (@redsand)

    Hi @starhorsepax2,

    This has already been fixed in version 1.9.9.8.3. We issued a fix after it was reported to us.

    – Scott

    New version 1.9.9.8.3 still throwing errors.

    2017/01/19 08:25:01 [error] 1410#1410: *69489 FastCGI sent in stderr: “ss.utils.php on line 637
    PHP message: PHP Warning: preg_match(): No ending delimiter ‘~’ found in /var/www/wp-content/plugins/wp-spamshield/includes/class.utils.php on line 639
    PHP message: PHP Warning: preg_match(): Delimiter must not be alphanumeric or backslash in /var/www/wp-content/plugins/wp-spamshield/includes/class.utils.php on line 637
    PHP message: PHP Warning: preg_match(): Delimiter must not be alphanumeric or backslash in /var/www/wp-content/plugins/wp-spamshield/includes/class.utils.php on line 639
    PHP message: PHP Warning: preg_match(): Delimiter must not be alphanumeric or backslash in /var/www/wp-content/plugins/wp-spamshield/includes/class.utils.php on line 637

    Plugin Contributor RSMG Tech Support

    (@rsm-support)

    Hi @scollonp,

    Version 1.9.9.8.4 was released earlier today. Are you still having issues with 1.9.8.8.4? If so, it may be a more specific conflict, so please submit a support request to us at the WP-SpamShield Support Page and we’ll help you get everything resolved.

    – Steven

    Please note that the WP-SpamShield Support page is our main support venue, not the WordPress forums here, so that will always be the best way to get a quick response and resolve any tech support issues. Please direct any further support questions there.

    efishinsea

    (@efishinsea)

    There are still problems with Version 1.9.9.8.6.

    Fatal error: Class ‘WPSS_Utils’ not found in /wp-content/plugins/wp-spamshield/wp-spamshield.php on line 7323

    When I try to install this plugin to my local server, it fails generically:

    “Plugin could not be activated because it triggered a fatal error.”

    disabling this plugin for now….

    • This reply was modified 4 years ago by .
    danerich

    (@danerich)

    +1 for this we experienced the same issue with version 1.9.9.8.6

    Plugin Contributor RSMG Tech Support

    (@rsm-support)

    UPDATE: Version 1.9.9.8.7 has been released. All issues should be resolved.

    If anyone needs further tech support, please visit the following:

    1. WP-SpamShield Support Page
    2. Troubleshooting Guide
    3. Frequently Asked Questions (FAQs)

    Hi guys,

    I write from Italy and I have the same problem. Do you know if the problem is solved automatically or you have to manually update via FileZilla?

    Let me know

    Plugin Contributor RSMG Tech Support

    (@rsm-support)

    Hi @marcello565,

    If your site currently has a 500 error (or white screen) you would need to do it manually.

    Just go into your site’s file structure by FTP (preferably SFTP) or with the file manager in your site’s web control panel. Just navigate to the /wp-content/plugins/ folder and delete the folder of the plugin – /wp-spamshield/. That will force-deactivate the plugin. Then you can install the updated version through the WordPress Dashboard.

    – Steven

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Auto updated and broke MANY sites’ is closed to new replies.