Support » Plugin: bodi0`s Easy cache » Auto-update no working

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Budiony Damyanov


    The cache is created on first access of the newly published posts / pages . If you have updated the post or page (or you have new comments), the cache file will be again recreated on first access of the updated page/post. So only the cache associated with this page/post will be recreated when page or post is updated, if you have other pages/posts with links pointing to the new posts – like menus, you`ll have to update them too (either place the correct links to that page, or just open and save the page without performing modification, this will trigger the cache recreation mechanism). Or, as final resort (if you do not understand what I’m trying to explain), clear the cached files, they will be recreated automatically on first access.
    If you provide me more specific details on what you have in mind maybe I could help?

    I’m also having the problem. I’ve just installed activated the cache, checked that the main page is cached, then I edited the most recent post, but when I refresh I get the old (cached) page with the old post content.

    Of course, I get the right page if I manually remove the cached pages via the admin page.

    Plugin Author Budiony Damyanov


    When you edit the most recent post, it’s own cache file will be re-created on update, not the cache file of the main page, i.e. the cache file for displaying the single post or page.

    If you display some excerpts of recent posts on your main page (for example via custom query loop in your theme), this information will not be updated, because the URL of the main page is different from the URL of the updated post(s).

    The Easy cache plugin perform its job based on the URL of the given page/post. As a work-around, indeed you may manually remove the cached file for your home page (that’s the main purpose of this option in Administration area).

    That means that the main page is always cached, and it only expires by time? Sorry, that’s not acceptable for me; after I post an entry I often make minor edits to it and I want them reflected in the main page.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Auto-update no working’ is closed to new replies.