Support » How-To and Troubleshooting » Auto-update fails — possibly due to PHP 5.3.x?

Auto-update fails — possibly due to PHP 5.3.x?

  • In trying to update a site from an older version of WP to the current 3.4.2, I ran across an interesting problem.

    I have a server called ‘ratbert’ that has several WP installations on it. I tried to perform an automatic update on one of them, and as usual I was presented with the FTP sign-in request. I entered my username and password, and was taken to the next page, where nothing happened. The update failed silently.

    I then set WP_DEBUG to TRUE, and tried again. I got a bunch of warnings, but nothing that appeared relevant to the attempted update. Once again, the update failed silently.

    I decided to copy the site to a different server and try the update there. (The site’s not in production, so I wasn’t real concerned with breaking stuff.) I got the site set up on the new server — named dogbert — and made sure it was working correctly. I then ran the automatic update.

    When I filled in the FTP credentials, I didn’t notice that the FTP server was still set to point to the old server, ratbert. After I successfully ran the update, the version on dogbert still indicated that it was the old version. But when I signed in to the site on ratbert, it was now showing version 3.4.2.

    I trawled through the WP forums and Google looking for help on a failed update; most of what I found seemed to point to a problem with PureFTPd, which is not in use on either server. (We have vsftpd installed instead.) The only difference is that ratbert is running PHP 5.3.3, and dogbert is running PHP 5.2.14.


    php -v
    PHP 5.3.3 (cli)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies


    php -v
    PHP 5.2.14 with Suhosin-Patch 0.9.7 (cli) (built: May 18 2012 14:06:28)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
        with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH

    Any suggestions? If you need more information, feel free to ask; I’ll provide what I can.

  • The topic ‘Auto-update fails — possibly due to PHP 5.3.x?’ is closed to new replies.