WordPress.org

Forums

Auto-update fails for plugins, WP 2.8.4 (6 posts)

  1. LoopyKnits
    Member
    Posted 5 years ago #

    I just upgraded to WP 2.8.4 and also need to update several plugins. But when I select "upgrade automatically" for a plugin, I get a fail message. And then the plugin folder **disappears** from my plugins folder on the server. This happens whether I select the "FTP" or "FTPS" connection type for auto-upgrade.

    I can manually place the updated plugin files on my site via FTP, but I'd like to use the automatic upgrade function. Any suggestion for what might be wrong?

    The error message looks like this below; this is copied from my attempt to upgrade the wp-email widget:

    Downloading update from http://downloads.wordpress.org/plugin/wp-email.2.50.zip.

    Unpacking the update.

    Installing the latest version.

    Deactivating the plugin.

    Removing the old version of the plugin.

    Could not remove the old plugin.

    Plugin upgrade Failed.

    Actions: Return to Plugins page

    ALSO: When I return to the main "Manage Plugins" page, I get this error message: "The plugin wp-email/wp-email.php has been deactivated due to an error: Plugin file does not exist."

    I have tried the step of de-activating all plugins, then attempting to upgrade one of the outdated plugins. Got the same error message.

  2. detroiter
    Member
    Posted 5 years ago #

    Having the same problem here and it seems so are many others. It was working fine for some time and then all of a sudden it wasn't working.

  3. Shane G.
    Member
    Posted 5 years ago #

    Hi,

    Assign 766 recursive permissions to wp-content directory and disable all the plugins which should resolve the problem.

    Thanks,

    Shane G.

  4. detroiter
    Member
    Posted 5 years ago #

    Looks like I figured out a solution others may want to try.

    1. Make sure your wp-config.php file is chmodded to 0644.

    2. Also make sure your .htaccess file is protecting the wp-config file using these lines:

    <Files wp-config.php>
    order allow,deny
    deny from all
    </Files>

    3. Backup your wp-config.php file.

    4. Edit your wp-config.php file putting these lines in underneath <?php:

    define('FS_METHOD', 'ftpsockets');
    define('FTP_BASE', '/path/to/wordpress/');
    define('FTP_CONTENT_DIR', '/path/to/wordpress/wp-content/');
    define('FTP_PLUGIN_DIR ', '/path/to/wordpress/wp-content/plugins/');
    define('FTP_USER', 'username');
    define('FTP_PASS', 'password');
    define('FTP_HOST', 'ftp.example.org');

    ---

    WordPress no longer asks me for FTP details and it seems that everything is now working as it should be as far as automatic upgrade/install of plugins.

    Make sure you leave the port (:21) off the end of the FTP_HOST line.

  5. plasticsman
    Member
    Posted 5 years ago #

    Thank you Detroiter .. this solution fixed my problem of the plugins not installing and saying that the directory exists when it does not!
    Thanks.

  6. Puma85
    Member
    Posted 5 years ago #

    @ Detroiter: Thank you very much!! I finally got it working :D.

    Just a small question.. is this a safe way to fix it? I mean I don't have any clue about what WP does, but does it affect any other functions like auto-update etc?

Topic Closed

This topic has been closed to new replies.

About this Topic