Support » Installing WordPress » Auto update 2.8 > 2.8.1 fail. “Could not copy file: wp-comments-post.php”

  • 2.8 to 2.8.1 auto update. Went for 3-4 minutes and gave me the following. Any idea what the problem is?

    Downloading update from

    Unpacking the update.

    Could not copy file: /public_html/wp-content/upgrade/wordpress-2.8.1/wordpress/wp-comments-post.php

    Installation Failed

Viewing 14 replies - 1 through 14 (of 14 total)
  • @mercime


    Volunteer Moderator

    Try FTP upload of WP instead.

    Automatic update doesn’t work on any of my 5 blogs either. This is very stressful. How about the developers get their ducks in a row before they release new updates?

    I too am having this problem. I have 20 blogs to update. Does anyone have a solution here?

    Same problem. One of my favourite new features of WP is the automatic upgrade – hate going back to FTP upload.

    Same problem here. I thought it might be mod_security so I tried turning it off in .htaccess. Still doesn’t work, though. I notice it has problems on all my dedicated servers, but no problems on my shared hosting accounts.




    Automatic update doesn’t work on any of my 5 blogs either. This is very stressful. How about the developers get their ducks in a row before they release new updates?

    yet another useless post. there is NO way that anyone developing wordpress can account for ALL the different hosting scenarios.

    If you cant do the automatic upgrade, and you dont find a “fix” on the forums or elsewhere, than you do the upgrade the ‘old fashioned’ way.

    and if you want to complain — complain to your host, or whoever admins the server youre hosted on.

    Tried checking the CHMOD permissions?

    – Pranav

    Same problem here, unfortunately.

    I tried it again and now it works. Weird?

    Here is what my host wrote (I have a dedicated server):

    That really depends. Here are some scenarios where it [automatic upgrade] would work without error:

    A webserver where everything is persistently kept to having 777 permission – VERY INSECURE.

    A webserver running php as suPHP, which reowns all processes to the UID of the user rather than the apache user (nobody).

    A blog where there are not modules that have created content on their own, which end up owned as nobody.

    Now for the solution. For the most part, upgrading can be handled through Fantastico (assuming wordpress was installed through it). This is slightly behind the lastest version as they iron out all the kinks to make sure it is compatible with their software.

    Alternately, you could convert your server to suPHP which requires all items to be owned by the individual users and have secure permissions.

    Or you could simply upgrade manually, correcting permissions as you went.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Few points:

    WordPress will not do an upgrade even with 777 permissions. It does a test first to check on the user of the resulting files. It won’t do it in “direct” mode if it only creates files set to a “nobody” user.

    The other modes available are all FTP modes, basically. It attempts to FTP back to the host, using the proper credentials, in order to upgrade the files as the correct user.

    Whether other modules created content or not is irrelevant. WordPress only upgrades itself, not these other modules.

    Fantastico is awful. I’ve never heard of an “upgrade” by them working properly. The most common scenario I’ve heard is that it simply wipes their blog. Avoid Fantastico at all costs, IMO.

    Converting to suPHP is a good idea, and fairly easy to do if you have your own dedicated host.

    Is suPHP uncommon? Will it cause me any headaches?

    So, for those people who do not have suPHP, and can do an auto upgrade, what else would cause me and others to not be able to auto upgrade?

    Are there any guides for server administrators and hosting companies to get WordPress auto update feature to work? It obviously fails miserably in a default install of centos or redhat… Surely there must be some documentation on how to configure your server to make this happen?

    For the record, I had this same problem and was able to upgrade WP from Fantastico via CPanel. However, I couldn’t upgrade the plug-ins that way.

    I upgraded 5 blogs today. 3 went fine and 2 had the problem this thread described. The two that had the problem were with the same host. The blogs with other hosts had no problems. So this seems like a problem on the host level.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Auto update 2.8 > 2.8.1 fail. “Could not copy file: wp-comments-post.php”’ is closed to new replies.