Support » Plugin: Widget for Google Reviews » Auto translates reviews

  • Resolved xariklios

    (@xariklios)


    Hello, We have an issue when we fetch reviews from google with the plugin. Even though the original reviews are in greek it displays them in English. Furthermore when we choose the Greek language in the shortcode tab, reviews_lang = “el”, it actually brings only one review, so it probably recognises wrongfully that the original reviews are in English even though some of the times it brings the reviews in greek correctly in preview (reviews tab).

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author richplugins

    (@richplugins)

    Hi @xariklios,

    First of all, you need to try to reinstall the plugin from scratch and reconnect your Google place in all current widgets and/or shortcodes depending from what you’re showing the reviews.

    Please make the following steps:

    1. Save Google Places API key and your Place ID somewhere except the plugin;

    2. Delete all your current widgets and shortcodes (deleting the current widgets/shortcodes is very important) where you have connected your Google place(s);

    3. Go to the page: WordPress Settings / Google Reviews Widget / Advance tab;

    4. Click ‘Install from scratch‘;

    5. Paste your Google Places API key to the settings;

    6. Reconnect your Place ID for all widgets and shortcodes with a selected language option.

    Please pay attention that in 5 point, you need to select your language BEFORE connecting your Place ID, because after connecting you can’t change it.

    Let me know how it goes.

    Thanks!

    Hi, I am having the same problem. I have done several installations from scratch, works for a few days and the problem comes again.

    This is the shortcode I usually use:

    [grw place_id=”********” pagination=”5″ text_size=”-1″ refresh_reviews=true lazy_load_img=true reduce_avatars_size=true open_link=true nofollow_link=true language=”es”]

    Even selecting a diferent language from english keeps overwriting this parameter.

    Plugin Author richplugins

    (@richplugins)

    Hi @garciaporto,

    Are you sure that you’re using only this shortcode and don’t any else? Because if you’re using any else with another settings, the language can change.

    In any case, please send debug information to support [at] richplugins.com.

    Thanks!

    I have the exact same problem.

    Plugin Author richplugins

    (@richplugins)

    Hi @mydas,

    See my previous answer here https://wordpress.org/support/topic/auto-translates-reviews/#post-14176398, please do it and let me know.

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.