Support » Plugin: Responsive Video Light » auto-start loop on Vimeo

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello,

    Ok when your create the embed from vimeo, there is a parameter to autostart – it’s in html is saw the code for some trials. Something like embed frame … autostart=yes…

    Just visited your site, just replace or add the last tiny part in your code:

    <iframe src=”//player.vimeo.com/video/121998615?title=0&byline=0&portrait=0″ frameborder=”0″ webkitallowfullscreen=”” mozallowfullscreen=”” allowfullscreen=”” autoplay</iframe>

    It’s possible i miss some close markup, but that’s it,

    Regards,

    Ah, Flash may be the issue so if the above doesn’t work, try to add this next – and tweak it with width and stuff:

    <object width=”WIDTH” height=”HEIGHT”>
    <param name=”allowfullscreen” value=”true” />
    <param name=”allowscriptaccess” value=”always” />
    <param name=”movie” value=”https://vimeo.com/moogaloop.swf?clip_id=VIDEO_ID&server=vimeo.com&color=00adef&fullscreen=autoplay” />
    <embed src=”https://vimeo.com/moogaloop.swf?clip_id=VIDEO_ID&server=vimeo.com&color=00adef&fullscreen=1=autoplay”
    type=”application/x-shockwave-flash” allowfullscreen=”true” allowscriptaccess=”always” width=”WIDTH” height=”HEIGHT”></embed>
    </object>

    Anyways HTML5 will go first to solution, then parse flash data in case,

    hello,

    thanks for quick answer !

    well, we are not really able to know what to do with all these codes…
    We use a template and we added your plugin to don’t have to manipulate codes.
    But any way, if we use the code from Vimeo, so we don’t use anymore your plugin ? or do we misunderstood something ?

    we added the Vimeo player with their own code under the video displayed with your plugin.
    As you see, it’s auto-start and looped, but not responsive.

    The 2 elements missing in your short code are loop=1 and autoplay=1.
    I don’t know how to add it and where !

    About the Flash code, I have no idea where to add it ? I tried to add it as a javascript code in my template, but that doesn’t work.

    here is the Vimeo code we added on the test page (http://www.growupplants.com/growupplants-home-responsive-video-light/) :
    <iframe src=”https://player.vimeo.com/video/121998615?autoplay=1&loop=1&color=e49ae6&title=0&byline=0&portrait=0&badge=0″ width=”1200″ height=”674″ frameborder=”0″ webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>

    First i don’t sell plugins, but let’s see sorry..

    The 2 elements missing in your short code are loop=1 and autoplay=1.
    I don’t know how to add it and where !

    1. Check the page where you have video (i hope it’s front page or so) then switch from visual view to text view.
    2. There you will see the full html of page
    3. That’s where you add the little parameter i said, or completely repaste vimeo embed code with only the autoplay paramater added

    For final notice, your last code is fine but still miss the “autoplay” word somewhere – example again i just added the word before “>” and that should work.

    <iframe src=”https://player.vimeo.com/video/121998615?autoplay=1&loop=1&color=e49ae6&title=0&byline=0&portrait=0&badge=0″ width=”1200″ height=”674″ frameborder=”0″ webkitallowfullscreen mozallowfullscreen allowfullscreen autoplay></iframe>

    i do a test on my blog to be sure:

    http://blog.digico.fr/news/vimeo-test/ works perfect.

    I think what you might have missed is this – when you copy paste exactly that,

    <iframe src=”https://player.vimeo.com/video/121998615?autoplay=1&loop=1&color=e49ae6&title=0&byline=0&portrait=0&badge=0″ width=”1200″ height=”674″ frameborder=”0″ webkitallowfullscreen mozallowfullscreen allowfullscreen autoplay></iframe>

    be sure to in TEXT and not VISUAL tab of the page – i put a screenshot to be more clear – difficult only with words 🙂

    View post on imgur.com

    so here –> be sure to be on text mode not visual to insert this vimeo code in page.

    I hope it will work now 🙂

    Plugin Author billknechtel

    (@billknechtel)

    I have just released version 1.4.0 of my plugin, which now supports autoplay and loop. Thank you for your support!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘auto-start loop on Vimeo’ is closed to new replies.