WordPress.org

Forums

Auto-save posts/pages. Option to turn it off. (10 posts)

  1. cheese apples
    Member
    Posted 6 years ago #

    I'd like to turn off the auto-save functions in WordPress when creating posts. If anyone knows how let me know please. This should be an option somewhere as well.

  2. ok_hp
    Member
    Posted 6 years ago #

    Me too. I really need this option.

  3. joeedmon
    Member
    Posted 6 years ago #

    Autosave is killing me. I am losing custom fields, publish states, and categories with this "feature". I am sorry I upgraded.

  4. cheese apples
    Member
    Posted 6 years ago #

    You can go to wp-settings.php in your blogs root.

    Change the line:

    define( 'AUTOSAVE_INTERVAL', 60 );

    to whatever. Can also be manually defined in wp-config.php.

  5. Roy
    Member
    Posted 6 years ago #

    I could get nothing to work but the Disable Autosafe plugin.

  6. joeedmon
    Member
    Posted 6 years ago #

    This feature does not work and has broken our workflow. Next time you guys have a really really cool option you think everyone in the world should be using please give us the option to turn it off. Also, this option should have been off by default, not on. I have been using WordPress since it was forked from b2. This is the first time I have said I hate WP. Now, for the first time, I'm worried about doing the regular updates.

  7. TBart777
    Member
    Posted 6 years ago #

    Man, I gotta agree with joeedmon. Autosave is killing me! EVERY autosave wipes out the page contents completely. Right now WordPress sucks piles. What the hell were you guys thinking forcing these features on users without any option to disable them? Regular updates? You gotta be joking - just give me the next (stable) version...

  8. observethebanana
    Member
    Posted 6 years ago #

    My big problem with the auto save is that the first save happens 1-2 seconds after opening the write post screen. It is a race to get a good title in fast enough or else the permalink gets set to something generic, or to only the first part of the title. Along with a way to turn it off all together, it would be nice if it waited the entire 60 second interval before the first save.

  9. Autosave should not happen at all until you type something into the post or type a title in or some such thing. It works for me, I can leave the screen up for several minutes on a background tab, and nothing happens until I go type in a title.

    Make sure you uploaded ALL of the WordPress files when you upgraded. Even the ones in the root (look closer at wp-settings.php).

  10. ninjaboy
    Member
    Posted 6 years ago #

    You can use the WP-CMS Post Control plugin over at http://wordpress.org/extend/plugins/wp-cms-post-control/ to turn off Autosave.

    It has a nice control panel that allows you to turn it on and off, along with post revisions, which also cause some people a bit of trouble. It also allows you to completely control every element of the write page so you can hide unwanted items easily, so you can hide things such as 'tags' if you wish or 'pings and trackbacks'.

Topic Closed

This topic has been closed to new replies.

About this Topic