WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Auto save creating multiple drafts (9 posts)

  1. Mark McKibben
    Member
    Posted 6 years ago #

    I recently upgraded one of my blogs to WordPress. Ever since doing so when WordPress auto saves a post I'm writing; it creates a new/separate draft. One particularly long post I was working on ended up creating 31 different drafts. I did some poking around the forums/codex/bugtracker, but didn't see any other reports of this. Bug? New feature? Something screwy in my install/upgrade?

    Vitals for this blog:
    PHP information
    max_execution_time: 30
    max_input_time: 60
    file_uploads: 1
    upload_max_filesize: 2M
    post_max_size: 8M
    register_globals:
    safe_mode:
    allow_url_fopen: 1
    eaccelerator.enable:

    Other information:
    PHP Server API: cgi
    WordPress Version: 2.5
    WordPress Theme: /wp-content/themes/outworld
    WordPress Permalink Structure: /%year%/%monthnum%/%day%/%postname%/
    WordPress wp-content directory is writable
    WordPress does not use Gzip Compression
    WP-Cache is running on this installation of WordPress
    GD library is installed
    PHP Version: 4.4.5
    MySQL Version: 4.1.22-standard-log
    Browser used: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

    Plugins Used
    -------------------------------------
    Akismet, v 2.1.4
    Bad Behavior, v 2.0.13
    Better Comments Manager, v 1.5.1
    Contact Form ][, v 2.0.13
    Comment License, v 1.2
    DoFollow, v 4.0
    Google XML Sitemaps, v 3.0.2.1
    Kottke Style Archive, v 0.4
    NextGEN Gallery, v 0.90
    NextGEN Gallery Widget, v 1.20
    Plugins Used Plugin, v 0.1.11b
    PHPInfo, v 1.1b
    Subscribe To Comments, v 2.1.2
    Search Everything, v 4.2.2
    Simple Tags, v 1.5.3
    ShareThis Classic, v 1.5.2
    TFS Core (Text Filter Suite), v 1.1
    Tagline Randomizer, v 0.99b
    TFS Pirate, v 1.1
    WordPress Database Backup, v 2.1.5
    wp-cache, v 2.1.2
    WordPress.com Stats, v 1.2

  2. fitztrev
    Member
    Posted 6 years ago #

    Are you using custom fields? If so, there's already a bug report of the problem.

  3. Mark McKibben
    Member
    Posted 6 years ago #

    Sure am, missed that bug when looking through the bugtracker. I hope they release the fix for that quick, the blog mostly affected by this uses custom fields extensively.

    Thanks!

  4. Ivovic
    Member
    Posted 6 years ago #

    Am I the only one who doesn't install new versions until the first maintenence release comes out? ;)

  5. Creationrobot
    Member
    Posted 6 years ago #

    Ivovic, probably :) I like the risk of the new toys personally.

  6. Mark McKibben
    Member
    Posted 6 years ago #

    @Ivovic: Nope, the only site I work at keeping the latest/greatest version is my test blog on my home server. All my production sites tend to stay on a version until I'm sure the plugins/themes I'm using are fully upgraded and I know things will work correctly. The site I upgraded and got caught with this bug was kind of an exception as I hadn't upgraded it for a while and wanted to get caught up a bit (e.g. was still on 2.2.x).

  7. Ivovic
    Member
    Posted 6 years ago #

    it's always the exceptions that hurt the most ;)

    anyway, good luck getting this fixed ASAP.

  8. nmarques
    Member
    Posted 6 years ago #

    you are very lucky... I have the same problem. The save button keeps working automatically and then i can't post, the publish button disappear

  9. Mark McKibben
    Member
    Posted 6 years ago #

    This bug appears to have been fixed in WP 2.6.

Topic Closed

This topic has been closed to new replies.

About this Topic