Support » Plugin: LiteSpeed Cache » Auto Request Cron

  • Resolved kinansy

    (@kinansy)


    Auto Request Cron is not working

    checked the WP scheduled actions and CP cron jobs. Can I add it manually in the CP cron jobs ?

    settings:
    – cache disabled for now
    – optimization disabled
    – image otimization is on auto is on
    – I have security on cloudflare blocking Bots and on wp disabling few things

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    please provide the report number , you can get it in toolbox -> report -> click “send to LiteSpeed”

    when you say not working as how ? image send but never pull back ?

    does it work if you manually process it ?

    Best regards,

    Thread Starter kinansy

    (@kinansy)

    Auto request doesnt start auto. same for auto pull
    manually yes it worked.

    where should that cron job be saved ? where can i check it ?

    i ll send a report when i have a chance and give the number

    Plugin Support qtwrk

    (@qtwrk)

    are you sure your cron is running ?

    1. you can install some kind of cron manager plugin to see the cron task

    2. set up a real-cron job on your system to trigger it , instead of use wp-cron , see how it goes

    Thread Starter kinansy

    (@kinansy)

    Report number: YJUJJVQJ

    Report date: 05/20/2021 18:44:04

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    checked the WP scheduled actions and CP cron jobs.

    What’s the cron job list and timing you see on WP scheduled actions ?

    Can I add it manually in the CP cron jobs ?

    if you have WP CLI , you can use

    wp litespeed-image push
    wp litespeed-image pull

    Best regards,

    Thread Starter kinansy

    (@kinansy)

    never tried CLI.
    i ll check it and i also found this support ticket
    https://wordpress.org/support/topic/problem-with-cron-to-pull-image
    looks exactly like mine

    but could you please explain this
    wget -q -O - http://yourdomain.com/wp-cron.php?doing_wp_cron >/dev/null 2>&1
    and then you say

    you only need one of them , make it 5 minutes or 10 minutes

    one of what ?

    Plugin Support qtwrk

    (@qtwrk)

    no no , that command is wrong

    you need to use it like cd public_html ; wp litespeed...... way

    and make sure your hosting provides WP CLI

    Thread Starter kinansy

    (@kinansy)

    sorry we were typing at the same time.
    I just edited my post. could you please check it now

    Plugin Support qtwrk

    (@qtwrk)

    okay , yes , that wget command should do it

    Thread Starter kinansy

    (@kinansy)

    I block mysite/wp-cron.php on cloudflare. could that be the cause ?
    so I added this
    wget -q -O – “/home/mysite/public_html”/wp-cron.php?doing_wp_cron >/dev/null 2>&1
    Run twice per Hour

    But still cant see what is telling to pull and optimize images ?

    Thread Starter kinansy

    (@kinansy)

    this is what i have now
    https://drive.google.com/file/d/1Xs02RHmZSyaqmZ2G1VZJtmPJEXdSLWg1/view?usp=sharing

    I just added the forth line now. the first 3 for the backup

    Plugin Support qtwrk

    (@qtwrk)

    no , wget -q -O https://domain.com/wp-cron.php?doing_wp_cron , not with /hoe path

    Thread Starter kinansy

    (@kinansy)

    Solved
    it was not a litespeed issue. i only added this in my C Panel
    /usr/local/bin/php /home/****/public_html/wp-cron.php >/dev/null 2>&1

    where *** is your username

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Auto Request Cron’ is closed to new replies.