Support » Plugin: WP2Social Auto Publish » Auto publish on editing posts/pages/custom post types

  • Hello,
    i have problem with this settings” Auto publish on editing posts/pages/custom post types”
    its set to OFF but when i edit post it publish post on fanpage
    i try to delete cache and disable and enable plugin

Viewing 6 replies - 1 through 6 (of 6 total)
  • If you are using any old version of WP2Social Auto Publish ,then please get the latest version.
    Also check the metabox settings on post edit page.
    If you have set ‘Auto publish on editing post/page/custom post types’ to ‘No’ then the permission to auto publish to Facebook is set to No by default and it will publish the post to Facebook ,only if you override it to Yes.
    Please check the settings .
    Hope this helps.
    Thank you.

    Thread Starter bartek4175

    (@bartek4175)

    i ahve newest version: 2.3.1

    Auto publish on editing posts/pages/custom post types is set to Disabled: https://imgur.com/a/pMWXvml

    logs: https://imgur.com/a/mllp1G0

    • This reply was modified 3 years, 11 months ago by bartek4175.
    • This reply was modified 3 years, 11 months ago by bartek4175.

    This is seems to be a conflict, the post publish time of the 2 posts have only few seconds difference.
    If you are using any other plugins for social media auto posting or any plugin related to the post publishing action,then please provide us the list of the plugins,we will check for the conflict.

    Thread Starter bartek4175

    (@bartek4175)

    it few seconds difference becouse i edit this post after few sec after publish 🙂

    my plugins: All In One WP Security, AMP, Autoptimize, Autoptimize CriticalCSS.com Power-Up, Brave Payments Verification, Countdown Widget, Head, Footer and Post Injections, Hummingbird, Cookie-Notice, Nofollow for external link, Really Simple SSL, Smush, W3 Total Cache, WP-PostViews, Yoast SEO Premium, Yoast SEO: News and WP2Social Auto Publish.

    it few seconds difference becouse i edit this post after few sec after publish

    The edit settings is followed on edit actions, but in this case ,if you are using gutenberg editor the update will not reload the page.
    Thus the settings of WP2Social Auto Publish(metabox) will be the same for create post.Since you are updating the post within seconds the meta settings will be followed and the post will be auto publish again.
    So please override the meta settings(Set,Enable auto publish post to my facebook account to No) or reload the post edit page after publish.
    Hope this helps.
    Thank you.

    I also confirm this issue.

    Your post helped me….

    Auto publish on editing post/page/custom post types : set to “No”

    But if I edit the post, it gets sent to FB again.

    However – if I first refresh the WP post edit page, then edit it and press update, it does not repost… Good to know 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Auto publish on editing posts/pages/custom post types’ is closed to new replies.