WordPress.org

Forums

Add Link to Facebook
[resolved] Auto Posting as Self, not as Page (5 posts)

  1. drewmaw
    Member
    Posted 3 years ago #

    Site: http://www.Vidgees.com
    Facebook: http://www.facebook.com/pages/Vidgeescom/142103132528318?sk=wall

    The Problem:
    When posting a new post on the site, it auto-posts as me (the facebook user), not the page (Vidgees). I want it to be able to post as if the page itself was posting, not me. I am the only admin on the page. I've deleted the posts and deactivated the plug-in for the time being. I guess I don't even understand how it could be posting as me (the facebook user), when I'm giving the API codes from the app. I'm perplexed!

    I've Tried:

    1.) I've set up the plugin to be authorized as "Add to Page: Vidgees | Video Game News"

    2.) I've tried it as both "Add to page as owner" enabled and disabled. Re-authorized in both occasions.

    3.) I haven't tried "Use Groups" enabled.

    Question:
    Is there a way to "Add post as page"?

  2. drewmaw
    Member
    Posted 3 years ago #

    OK, I figured out a kink:

    I went to the Vidgees facebook page and clicked "use Facebook as Vidgees". I posted a test article, and what do you know: it auto posted as Vidgees, not me (the facebook user), to the Vidgees facebook page.

    So, because I don't want to leave "use Facebook as Vidgees" enabled on facebook, this poses quite the conundrum. Is there anyway to get around this problem?

    Drew.

  3. drewmaw
    Member
    Posted 3 years ago #

    Checked a few more things:

    I tried creating a brand new user called Vid Gees. I made him Admin, then removed me as Admin.

    Now, I'm logged in as Vid Gees (as a facebook user), the sole admin on the Vidgees page. Oddly enough, now I can't even tell the plugin to Authorize for Vidgees "the page", only Vidgees "the app". Probably due to my main account being the authorized user for the app. Clearly, there must be some way to be able to make it so that the Vidgees facebook page can post these stories without me having enabled the "Use Facebook as Vidgees" option.

    This is driving me crazy!

  4. drewmaw
    Member
    Posted 3 years ago #

    HAHA, never mind. I figured it out.

    Couple things actually:

    1.) If you're having this problem: make sure to click "Add to page as owner" enabled, click "Save". THEN Authorize. If you don't click SAVE!!!! then it doesn't authorize the option as saved. LAME.

    2.) If you want to like and comment on your websites news articles as a regular user, make sure to create a fake user to admin the page you've created for your site. This makes it so you can un-admin yourself, allowing you to comment and like like a normal user, opposed to the page entity.

    CASE CLOSED!

  5. WPITn2shape
    Member
    Posted 3 years ago #

    The settings language is not clear, so I wasn't sure if I had done it right. After it published as ME I deleted it, which led to the plugin not working. I'd have to finish a new post to test it. Let's hope it works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Add Link to Facebook
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic