WordPress.org

Support

Support » Plugins and Hacks » NextScripts: Social Networks Auto-Poster » [Resolved] Auto poster loads the wrong image

[Resolved] Auto poster loads the wrong image

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author NextScripts

    @nextscripts

    Plugin takes featured image from the post. if there is no featured image it will take the first image from the post body. if your post body has no images it will take the specified default image. if default image is not specified it will take first image from the page.

    Please set featured image to clearly define what image you would like to show or specify Plugin Settings->Other Settings->”Open Graph” Tags->Default Image URL for og:image tag for the default image.

    Image must be set at the time you hit the “Publish” button. Some third party plugins that make posts sometimes publish post without featured image and then add it later. If this is your case, you can try to delay the autoposting for several minutes.

    Stolwij

    @peter-stolwijk

    I did the following things:

    1. I activated Add Open Graph Tags.
    2. I left the Default Image URL for og:image tag BLANK, because i didn’t know what to insert there)
    3. I deactivated verified “Featured” Image, and later activated again.

    But nothing helped.

    Did i do everything right?

    Thank you!

    I’m having the same problem – using the Text Link with “Attached” Post option (share a link to your blog post), and when the post goes through to my Facebook page, it’s pulling a random image from the top of my site as opposed to the image from the post itself.

    I’ve done the same steps as Peter above (clicked the “add open graph tags” box), but have no idea what – if anything – to input in the Default image URL text box.

    Otherwise everything is fantastic with the plugin, so thank you!

    Stolwij

    @peter-stolwijk

    May it help, i will post my facebook page here.

    Maybe there’s someone who could see from the type of posting, a wrong setting. This is my test page: https://www.facebook.com/parfumx.nl

    Please help the hob admin and myself.
    Thank you!

    Plugin Author NextScripts

    @nextscripts

    The most important part is this:

    Image must be set at the time you hit the “Publish” button. Some third party plugins that make posts sometimes publish post without featured image and then add it later. If this is your case, you can try to delay the autoposting for several minutes.

    Try to come back to your post and click “Repost” button. If repost will be done with the correct image then this is your case.

    Stolwij

    @peter-stolwijk

    Yes you are right!

    Sometimes they add a picture a minute later to it.
    But the pictures that are not delayed, doesn’t show either.

    And how can i choose to delay posts?
    Do i need to choose schedule?

    And what are the correct settings now, because i letterly tried everything! Maybe a possibility that i can import settings from you?

    Please help sir!

    Plugin Author NextScripts

    @nextscripts

    Stolwij

    @peter-stolwijk

    I have the free version sir.
    Please help

    Stolwij

    @peter-stolwijk

    Anyone?

    Plugin Author NextScripts

    @nextscripts

    What kind of answer you are still looking for?

    The answer is:

    Image must be set at the time you hit the “Publish” button. Some third party plugins that make posts sometimes publish post without featured image and then add it later. If this is your case, you can try to delay the autoposting for several minutes.

    Regulary configured WordPress has featured image ready at the time of the post.

    You have some advanced functionality that adds featured image later when the post is already published. You can find out what delays featured image and turn it off or you can upgrade to the “Pro” plugin and use it’s advanced functionality (delayed postings) as a workaround for your already implemented advanced functionality.

    Stolwij

    @peter-stolwijk

    Im sorry, i just can’t follow your steps.
    I just disable the images, have no other choice.

    Anyway, thank you very much for your time!

    hi all, just to add to this discussion:

    I have disabled WP-Cron.
    I set up a manual cron script which triggers WP-Cron in 5min intervals.

    The following is completely reproducible:
    1. I set up a new post.
    2. The very first time I publish this post, SNAP will take the correct picture.
    3. The next time i re-publish ANY post, SNAP publishes that latest successfully posted picture to Facebook
    4. This picture keeps on getting posted in every “old” post i repost
    5. When I publish a new featured picture in a new post, SNAP takes that very pictures as a new “reference” and posts that one from then on

    My questions are:

    – what’s going on here?
    – What are the names of those “third party plugins that make posts sometimes publish post without featured image and then add it later”
    – Will “Reset all SNAP Data” help in the case of republishing?
    – WIll re-publishing with a newer date and time in the near future help?
    – Will a shorter update of WP-Cron help (e.g. 1min?)

    I am really lost here. The post function is almost unusable.

    Plugin Author NextScripts

    @nextscripts

    flowerman653, you must create your own thread. This forum does not allow posts in other users threads, unless you are providing an answer.

    The answer is in the FAQ – #1.5: http://www.nextscripts.com/support-faq/#q15

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Auto poster loads the wrong image’ is closed to new replies.
Skip to toolbar