• Resolved lanxalot

    (@lanxalot)


    Autoplay only works when you arrive on the page from a link within the website. If I click on the website link in Google for example and arrive on the homepage for the first time, the sound does not play. This is true for both the mobile and desktop. When I go to another page on the website, then navigate back to the homepage via the menu or other internal link, the track then plays.

    I do not want the controls to be displayed on the page, I just want the sound to play when you land on the page, and especially when someone first lands on the website from a search engine (or any external URL).

    Many thanks for your help.

    Here’s the code I’m using. The site is under construction so hidden by a holding page so you won;t be able to see it.

    [sc_embed_player autoplay=true fileurl=”https://uploadad-mp3-url.mp3″%5D

    • This topic was modified 1 year ago by lanxalot.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, can you share the URL so that I can check myself.

    Thank you.

    Thread Starter lanxalot

    (@lanxalot)

    Ok, many thanks….. Here’s a bypass link to the homepage

    https://quickforget.com/s/2ad2b52caa79420ea959d7a1fd5c7090fcf56b5a1292e59a

    Plugin Contributor mbrsolution

    (@mbrsolution)

    I checked your home page and could not find the shortcode anywhere. Did you use the following php code in your theme to play your mp3 file?

    <?php echo do_shortcode('[sc_embed_player autoplay="true" fileurl="URL OF THE MP3 FILE"]'); ?>

    Kind regards.

    Thread Starter lanxalot

    (@lanxalot)

    This is the code that I have used:

    [sc_embed_player autoplay=true fileurl=”https://rusticcountryretreats.co.uk/wp-content/uploads/2023/07/birds-chirping-ambiance-26052.mp3″%5D

    I added it to the page content in a shortcode block, not via PHP

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, there might be something in your site interfering with the autoplay parameter. Can you try adding the php code I shared above to your theme. This might work better in your case. Let me know how you go.

    Kind regards.

    Thread Starter lanxalot

    (@lanxalot)

    Thank you. That is working now 🙂 Great stuff!!!

    Plugin Contributor mbrsolution

    (@mbrsolution)

    I am glad the issue is resolved. I will mark this thread as resolved.

    Kind regards.

    Thread Starter lanxalot

    (@lanxalot)

    Hi again,

    Unfortunately the sound has stopped working again. I made no changes to the code or any other but after approximately 48 hours, no sound plays on the site. Even if you visit the homepage from a link within the website. Before, the sound only played when you visited the homepage from a link or click on the website, but not from landing there from a search engine. Now there is no sound at all. I also tried getting the sound to autoplay on a different page of the site, but nothing. Just silence.

    Do you have any idea why this might have happened and any suggestions for a fix?

    Many thanks

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Unfortunately the sound has stopped working again. I made no changes to the code or any other but after approximately 48 hours, no sound plays on the site.

    Something in your site is probably interfering with the sound playing automatically. This could be related to a plugin or theme conflict.

    Kind regards.

    Thread Starter lanxalot

    (@lanxalot)

    Ok, thanks for your time. I’ll test for conflicts.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Auto play not working from external links on android mobile or desktop’ is closed to new replies.