W3 Total Cache
[resolved] Auto minify not working (27 posts)

  1. zappmania
    Posted 3 years ago #

    My site runs on the latest version of WordPress on a shared Windows server
    The previous version of W3TC was doing a fantastic job of minifying. Since upgrading, NOTHING works. I get a constant "Minify Auto encountered an error. The filename length value is most likely too high for your host. It is currently 150. The plugin is trying to solve the issue for you: (solving ...)" error every time I enable minifying. I have played around with the filename length values but no luck.
    details are given below :

    Site: http://www.zappmania.in

    Plugin Version:
    PHP Version: 5.2.17;
    Web Server: Microsoft IIS
    FTP functions: Installed (required for Self-hosted (FTP) CDN support)
    Multibyte String support: Installed (required for Rackspace Cloud Files support)
    cURL extension: Installed (required for Amazon S3, Amazon CloudFront, Rackspace CloudFiles support)
    zlib extension: Installed (required for compression support)
    Opcode cache: Not installed
    Memcache extension: Not installed
    HTML Tidy extension: Not installed (required for HTML Tidy minifier suppport)
    Mime type detection: Not installed (required for CDN support)
    Hash function: Installed (hash) (required for NetDNA / MaxCDN CDN purge support)
    Safe mode: Off
    Open basedir: Off
    zlib output compression: Off
    set_time_limit: Available
    Additional modules

    New Relic
    PHP version: Supported
    Operating System: Not Supported. Windows NT BJJI-GLOBEDNS 5.2 build 3790 See NewRelic requirements page.
    Web Server: Not Supported. Microsoft-IIS/6.0 See NewRelic requirements page.

    Fancy permalinks: /%year%/%monthnum%/%day%/%postname%/
    WP_CACHE define: Defined (true)
    URL rewrite: Disabled
    Network mode: No


  2. astrasuite
    Posted 3 years ago #

    Looks like this is a common problem, hope W3TC developers fix it ... no such problem in previous version.

  3. BlueNoseBear
    Posted 3 years ago #

    I have this issue with The filename length value also, no matter what I change the number to the error keeps coming back.

  4. leanderbraunschweig
    Posted 3 years ago #

    Same here! This error popped up since the last update.

    @zappmania: Where did you get the server debug infos from? Couldn't fin a corresponding option within W3...

  5. zappmania
    Posted 3 years ago #

    @leanderbraunschweig : Click on compatibility Check button on W3TC Dashboard

    currently i have disabled Minify and my site is up and running Hope W3TC developers fix it ASAP.

    [Signature moderated]

  6. Tarun Bansal
    Posted 3 years ago #

    I am also facing same problem in new version but if you check properly you will find that the minify functionality is working properly. It is just showing that error message in admin panel whenever you change any settings related to minify.

    Hope Frederick Townes solves the issue soon and post any patch for solving the problem in version if possible.

  7. zappmania
    Posted 3 years ago #

    Hi noushter,

    I have double checked this and than post this issue. it was not working correctly. this issue actually messed all my sites design and functionality. later I disabled minify setting and it was up and running with proper design with some performance downgrade.


  8. Tarun Bansal
    Posted 3 years ago #

    Hi Zappamania,

    Yes that may be case with you, in that case i would suggest you to have a look at your reqrite rules again. Thoush plugin would have been showing an error to corrent rewrite rules with suggestions but you can them again.

    I am using nginx and php5-fpm and i am developing a small plugin for maintenance mode and other settings. you can have a look at the source at

    Thank you

  9. frg
    Posted 3 years ago #

    same here... :(

  10. theComplex
    Posted 3 years ago #

    Since the latest update, I've been experience the same problem. I've had to disable Minify altogether.

  11. massimopaolini
    Posted 3 years ago #

    I'm also getting this error in my admin panel for one of our sites (wp3.5.1): "Recently an error occurred while creating the CSS / JS minify cache: No sources to serve.' and the following email is sent to us:
    "Unfortunately, an error occurred while creating the minify cache. Please check your settings to ensure your site is working as intended."

    Any advice?

  12. PE-Pernet
    Posted 3 years ago #

    Same here. Hope fix will come up soon

  13. micjamking
    Posted 3 years ago #

    Bump! I've had to disable Minify settings as well.

  14. Pseric
    Posted 3 years ago #

    The new version has been released,
    and it's fix this issues!

  15. leanderbraunschweig
    Posted 3 years ago #

    Unfortunately, didn't fix things for me... I still get the "The filename length value is most likely too high for your host"-error and the setting to disable the filename length check doesn't help (minify is not working).

    I have had this working before so it sure has to do with the update(s) made.

    I'll try manual minification and see if that is an option...

  16. Anonymous972
    Posted 3 years ago #

    Yes, and not only the minify auto error,

    but now, I can not save a "Minify error notification:", always defaults to Disabled.

    CSS files are not minifying, regardless of compression tool or any settings. They combine, but do not compress, remove white space or lines.

    Memcached is set, but saves files to disk in 00000 folder. clear cache does not work, need to delete files to refresh. they write once, and never get updated.

    otherwise, it works just fine :)


  17. astrasuite
    Posted 3 years ago #

    css files are not minifying like they used to ...

    I disabled the filename length check, but it only helps not to show the warning message. Auto Minify still does not work for CSS.

    Why ruin a good thing ? It used to work just fine before the last 2 updates.

  18. leanderbraunschweig
    Posted 3 years ago #

    Well, they obviously wanted to improve their product and not cause for an error like this. Let's just hope they are working on it and we can again be thankful for such a brilliant (free!) plugin. Just my 2 cents.

  19. astrasuite
    Posted 3 years ago #

    Well, I take back what I said. I downgraded to 2 versions back and it is still the same css not being minified, it seems. If I remember correctly, I may be wrong of course, the css was minified in the older versions that when one looks at the generated html code, everything is unreadable. This time, I see css lines clearly arranged in rows, easily readable.

    Anyway, I didn't complain 2 versions back, so I guess it's fine with me. I can always use BWP-Minify if I feel like it ...

    Thanks, W3TC guys, at least for the cache part which still works great !

  20. Frederick Townes
    Plugin Author

    Posted 3 years ago #

    The latest version gives option to disable the test and enter a value manually. Default value before was 150 characters. Since different servers support different file name length limits, the plugin needs to try and find the optimal length. The longer the file name supported the fewer minified files are generated per page.

    @leanderbraunschweig Does wp-content/cache/minify/.htaccess contain text should be rewrite rule, rewritecond etc. If not try to add the minify rules from the install page of the plugin manually. If this doesnt help could you send a bug report from the support page so we can look closer?

    @astrasuite Do you have Minify Debug enabled?

  21. astrasuite
    Posted 3 years ago #

    @Frederick, no, it is disabled ...

    Our website is at :


    Maybe you can just do a quick glance at the page source and see if css minify is working as normal or not ... I am not sure at the moment.

  22. Frederick Townes
    Plugin Author

    Posted 3 years ago #

    If you can submit a bug submission from the support tab of the plugin I can take a look.

  23. leanderbraunschweig
    Posted 3 years ago #

    @Frederick The .htaccess does list Rewrite Rules etc. so that isn't the issue – since the problem persists I went ahead and submitted a bug report. Looking forward to you/your team looking into it. Thanks.

  24. Patrick Whitty-Clarke
    Posted 3 years ago #

    Is there anywhere we can download the old version from? I was getting the same errors described in this thread, and now on a different server I'm getting the random blank white pages issue on some pages, which only seems to occur after visiting the page a few times.

  25. leanderbraunschweig
    Posted 3 years ago #

    Check out http://wordpress.org/plugins/w3-total-cache/developers/ - that's the tab listing the previous versions for WordPress-plugins

  26. zappmania
    Posted 3 years ago #


    New version is cool and works great.

    Developer thanks for fixing the issue My new rating is 5 out of 5

    [sig moderated as per the Forum Rules]

  27. carras
    Posted 2 years ago #

    I stopped the automatic file length, then a choose a number that works with my server.

    In my case I choose the bigger one 246.

    For those people that are getting this error:

    "The filename length value is most likely too high for your host"

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic