Support » Plugin: Relevanssi - A Better Search » Auto-indexing problem after upgrade to WP 4.6?

  • Since upgrading to WP 4.6, I’m seeing a nightly error in my logs on one of my sites using relevanssi:

    [08-Sep-2016 05:00:29 UTC] PHP Fatal error: Call to undefined function is_plugin_active() in /home/XX/public_html/wp-content/plugins/relevanssi/lib/indexing.php on line 733

    Auto-indexing appears to be failing.

    Anybody else seeing this?
    Cheers.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mikko Saari

    (@msaari)

    That function has not changed in WP 4.6. You’re seeing the error because the is_plugin_active() is only defined in WP admin.

    It also shouldn’t affect automatic indexing much, as indexing is always done in WP admin when posts are saved. It’s rare for posts to be saved outside WP admin.

    Anyway, this is a known problem and will be fixed in the next version to make sure the function is always defined.

    Ok, cheers Mikko! Not sure what’s kicking it off in our case, but maybe it’s something to do with auto-scheduled publishing, as it seems to coincide with that.

    I have noticed similar issues, so the knowledge of a fix is on it’s way makes me happy 🙂

    This error happens for the indicated reason when running a CRON task which creates/updates/publishes posts. It blocks any further processing in a loop, which is inconvenient, as the script can only do one post at a time (instead of several dozen).

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Auto-indexing problem after upgrade to WP 4.6?’ is closed to new replies.