Support » Plugin: Forminator - Contact Form, Payment Form & Custom Form Builder » Auto generated password in Email

  • Resolved yourtrustedfreelancer

    (@yourtrustedfreelancer)


    Hello,
    I really love this plugin and what it offers, I am using a registration form and it is working great, but I don’t have a password field and I use auto generate password option, however, I was not able to see an option to send that password in the email notification to the client, is there any way I can include the auto generated password in the email.
    Many Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @yourtrustedfreelancer

    I hope you are doing well.

    I was able to see this when we remove the password field.

    A workaround is adding the password field back, make it not required, and then use the CSS to hide the field.

    #forminator-module-ID #password-1{visibility: hidden; display: none;}

    replace the -ID using your form ID, for example, #forminator-module-2222.

    You can add on Forminator > Form Appearance > Custom CSS

    I will report this to the plugin team and check if we can improve the behaviour on the future,

    Best Regards
    Patrick Freitas

    Thread Starter yourtrustedfreelancer

    (@yourtrustedfreelancer)

    Hey, thanks for replying.
    I did what you suggested but I don’t see how the auto generated password will be sent via the email.
    If I place the password field and set the password as “password-1” the form won’t be submitted unless that field is filled, and if I set auto generated password, the password won’t be sent since “password-1” is empty.
    The only workaround I found is to cancel the email to client by the form and use the WordPress activation email and edit its content.
    Thanks again, I hope this issue will be resolved in future updates, your plugin is one the best form plugins.

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @yourtrustedfreelancer

    If the password field is not set as required, like Patrick mentioned above, then the form is able to get submitted. I’d also tested that on my end.

    If you’re still having issues with this, could you export the form, upload it to a service like Pastebin/Dropbox and share it here with us in order to further examine it?

    Thank you,
    Dimitris

    Thread Starter yourtrustedfreelancer

    (@yourtrustedfreelancer)

    Hi,
    It seems it is still not clear what my issue is. What I am trying to accomplish is sending the auto generated password inside the email notification when a user registers, I tried adding a hidden not required password field but that didn’t work.
    The solution is to add an auto generated password tag in the email notification content so the new user knows what the password is for his/her account.

    Thanks

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @yourtrustedfreelancer

    Thanks for response and sorry for confusion!

    I don’t think it’s possible at all, actually. If we don’t let user specify the password and let it be auto-generated then it is WordPress that generates it. The password is hashed with salt (it’s one-way encrypted) and it’s stored in the database in this encrypted form. It’s not “symmetrical” encryption so we can’t read the password from the database, decrypt it and send to user.

    The closest it can get to it is to either let user actually set their password or to go with auto-generated password and make sure that WordPress is allowed to send activation e-mail (in “User Registration” settings of the form set “Activation method” to “Email Activation”) as this should include a link letting them set their password.

    Kind regards,
    Adam

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hello, we haven’t heard back from you in a while so we will close down this ticket, if you have any followup questions feel free to reopen it.

    Cheers,
    Predrag

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.