Support » Plugin: Yoast SEO » Auto Generate Twitter Card (Title & Description) Missing

  • Resolved tinzion

    (@tinzion)


    Hi, I have problem with my twitter card my Title and Description for twitter is not auto-generated by Yoast plugin can you help me with this problem? thank you

    https://homelinkcincinnati.com/

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    This is expected. Twitter will fall back to Opengraph Tags (the tags used by Facebook). We looked at https://homelinkcincinnati.com and we can see Yoast is outputting a specific image for Twitter and those fallback tags.

    If you want a specific title and description for Twitter you will need to go the page on the backend and click on the Social section in the Yoast Metabox (the box that appears at the bottom of the page). Then enter in a specific title and description into the fields.

    Be sure to then clear your caching and when you share it to Twitter you should see that title and description appear.

    Thread Starter tinzion

    (@tinzion)

    Hi, Pcosta88 also I have a website https://www.fitzgeraldhr.co.uk/ twitter site meta is missing even I set up the twitter account on the backend?

    Plugin Support Michael Tina

    (@mikes41720)

    Hello @tinzion

    For your website https://www.fitzgeraldhr.co.uk/ we do see that it is outputting the relevant Twitter meta data such as the title, card type, and description. Could you please clarify what sort of meta data you are looking for?

    You can refer to this article for more information — https://yoast.com/help/twitter-sharing-not-working/

    Thread Starter tinzion

    (@tinzion)

    H Michael Tina

    I’m looking for:

    <meta name=”twitter:site” content=”somecontent” />

    I just add the twitter site on the social account in setting

    Hope you can help me with this

    Thread Starter tinzion

    (@tinzion)

    I figure out it now Thank you for your assistance

    Plugin Support devnihil

    (@devnihil)

    @tinzion Thanks for confirming you’ve resolved the issue. We are going ahead and marking this issue as resolved but please let us know if you require any further assistance.

    Thread Starter tinzion

    (@tinzion)

    Hi Devnihil sorry for that but I inspect my site https://www.fitzgeraldhr.co.uk/ the <meta twitter:site content=”@fitzgeraldhr”> is missing or not present can you help me with this?

    • This reply was modified 1 year ago by tinzion.
    Plugin Support Michael Tina

    (@mikes41720)

    Hello,

    We’re not sure which meta tag you are referring to. You can review the output that the plugin generates for Twitter here — https://developer.yoast.com/features/twitter/functional-specification

    Please note that for a lot of tags, Twitter falls back on OpenGraph metadata. Where it falls back, we provide the OpenGraph metadata and don’t provide the Twitter tag specifically unless it has been customized.

    Thread Starter tinzion

    (@tinzion)

    Hi Michael TIna

    I’m looking for this metadata “twitter:site The twitter handle of the site owner/operator.” it’s not appearing on my page source

    I already set up twitter username in the social account in setting

    • This reply was modified 1 year ago by tinzion.
    Plugin Support devnihil

    (@devnihil)

    @tinzion In order for this metadata to be output you would need to set up your Twitter account in the plugin’s social settings. You can do this by performing the following actions:

      In WordPress, go to SEO>Social
      Click on the ‘Accounts’ tab
      For ‘Twitter Username’ enter your username
      Click ‘Save Changes’

    After configuring your Twitter account in the social settings, you should then see the <meta name="twitter:site" content="@YOURUSERNAME" /> output in the page’s metadata.

    Thread Starter tinzion

    (@tinzion)

    Hi Devnihil already did that but it does not appear the <meta name=”twitter:site” content=”@YOURUSERNAME” /> in first when you put the username it will appear on the site but when you try it on incognito it will not appear also when I clear the browser cache. do I need to use the cache plugin?

    Plugin Support Pcosta88

    (@pcosta88)

    @tinzion

    We are not sure why the Twitter:Site meta tag is failing to appear. If you entered it in the SEO-Social-Accounts-Twitter Field section we would expect it to be outputted.

    Since it is not appearing, it sounds like a plugin or theme conflict. Can you try and gather as much information for us as possible? Please perform the following:

    1. Are all your non-Yoast plugins and themes also updated?

    2. Clear all your caching on your site.

    3. If the meta tag fails to appear after clearing all the caching, please Check for conflicts.

    If there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.

    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    Plugin Support Jerlyn

    (@jerparx)

    Hi @tinzion ,

    We’re closing this thread because there seemed to be no other concerns from you. Should you have further questions, please open a new thread.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Auto Generate Twitter Card (Title & Description) Missing’ is closed to new replies.