Support » Fixing WordPress » Auto excerpts are not generating on Bangla language mode

  • Excerpt works fine in English language mode. When I go to the Dashborard > Settings > General Settings and change Site Language to বাংলা (Bangla), then auto generated excerpts (First few words of first paragraph) are not generating/showing.

    I tested it using Twenty Twenty-One theme in several WP versions. Then I found that, upto version 5.2.9 there was no such problem. From version 5.3 this problem is occurring.

    I have no idea how to solve this problem. Probably a WP Core problem.

    I asked the question on StackExchange around two months ago. But still helpless.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Would you please report this following the steps at https://make.wordpress.org/core/handbook/testing/reporting-bugs/ so the developers can take a look?

    Thanks!

    Fahim Murshed

    (@fahimmurshed)

    Greetings for the day! Please provide us with some more information on how to reproduce; maybe we can help you better. It would be great to make a short video and indicate the issue you faced on your end.

    By the way, you have a nice site in the Bengali language. We have dedicated support forums. I am welcoming you over there for Bengali support.
    
    Looking forward to hearing from you.

    Thread Starter Md. Iqbal Kabir

    (@ikbir)

    Hi Fahim Murshed,

    I have already submitted a ticket for this issue.

    However, here are the steps to reproduce the problem:

    1. Go to WordPress Dashboard.
    2. Activate Twenty Twenty-One theme.
    3. Go to Settings > General Settings and change Site Language to বাংলা (Bangla)
    4. Click on Save Changes button to update the settings.
    5. Now go to your BLOG HOMEPAGE and see the problem (No excerpt, just Continue reading link)

    Thanks to all.

    P.S.: I cannot see any option to upload a screenshot.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    You can attach a screenshot or video to the ticket, and it would probably be best to continue the discussion there as the developers monitor Trac more regularly than the forums: https://core.trac.wordpress.org/ticket/53466

    Please follow the @macmanx suggestion.

    @ikbir Localizators for this language have translated numeric values to chars which probably breaks excerpt generation (link). Try to contact them to correct this.

    Thread Starter Md. Iqbal Kabir

    (@ikbir)

    @r33d3m33r Following your suggestion I have submitted a request to change those values to English. I hope it will be corrected in next release of WordPress. Meanwhile I am using a custom function to override default excerpt behavior.

    function custom_excerpt_length($length){
    	return 55;
    }
    add_filter('excerpt_length', 'custom_excerpt_length');
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.