WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Auto-enclosure of .m4a not working

[Resolved] Auto-enclosure of .m4a not working

  • I am setting up a podcast web site and my media are all .m4a “enhanced podcast” files that work with iTunes. I can’t seem to get the enclosure to automatically be created. It works for an .mp3, but not the .m4a. Is there something I am missing on the server to make it work properly? Otherwise, is there a way to hack it to make WordPress use getid3() to pull the information about the files? It seems to work okay for the WP-iCatter plugin if I manually add the enclosure.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I thought that this had been tried already, but it must not have been. I had asked my server admin to see if he could add the .m4a file type to the server, but he must not have made it to that.

    So, to solve my problem I uploaded a .htaccess file that had this line: AddType audio/x-m4a .m4a

    And it worked great!

    Got the information from this topic, http://wordpress.org/support/topic/47284

    I don’t think the solution provided here is the right one … I am having the same problem as the original poster. I can’s get an m4a to attach itself to the RSS feed. It is as if WordPress doesn’t recognize it as a format that is added as an enclosure to the RSS feed. Any help would be greatly apprecaited. I want to be able to link to m4a files that are either in my wordpress directory or from another server. Any thoughts?

    Yeah, WordPress is pretty conservative about what it encloses. Use my plugin to enclose anything you want. http://www.15framespersecond.com/enclosureflex/

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Auto-enclosure of .m4a not working’ is closed to new replies.
Skip to toolbar