Support » Plugin: WP-Members Membership Plugin » Auto-Email not working for Free email services

  • Resolved Tim Derouin


    I am having an issue where the auto-generated emails are not being sent out with passwords to some free email services (ie AOL, Comcast, live etc.)

    If a new user enters an address that is from their own domain the messages send out perfectly. Also, Gmail works which is strange because I typically have issues with Gmail in these types of situations but those emails show up in the Gmail inbox almost instantly with the WP-Members plugin.

    The “From” email address ( used is from the websites own domain ( That being said, I don’t see why I would need to use an SMTP plugin to override the default PHP mail function. I did test some SMTP plugins and every time I sent a test email, to any email address, none of the test emails worked until I switched it back to the PHP mail function. (I have also logged into a “” email account and was able to send emails to AOL and Comcast successfully.)

    I have tried deactivating all other plugins to see if something was conflicting there and that did not help. I also switched to a default theme as opposed to the custom theme I have setup and again no solution there.

    The site is hosted on Dreamhost and I have sent them a support ticket as well to see if the issue is on their end.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Chad Butler


    I would start by looking to see if the emails you indicate “are not being sent” are actually ending up in the spam filter. wp_mail and the plugin don’t have any mechanism to not send a message, so this is not an issue of the email not being sent to that user. It is not being received.

    So you need to figure out if that is happening at the user’s spam filter, at the domain level (such as, or at your host. (Troubleshooting this has nothing to do with this or other plugins nor your theme.) My guess is that it is not an issue with your host because as far as I know, Dreamhost does not restrict emails from wp_mail in the way that we are talking about here. If I had to speculate, I would say your messages are being flagged as spam.

    One solution might be to add an appropriate “from” name to the email’s headers. Some email hosts will flag as spam messages that lack this in the header. The plugin has a filter hook for the email headers wpmem_email_headers and there is an example script there that does exactly that (note: if you know nothing of how to use WP hooks, these go in your theme functions.php file)

    I don’t see why I would need to use an SMTP plugin to override the default PHP mail function.

    Because sending via an authenticated SMTP server makes the email more valid to the receiving mailserver. In fact, some hosts require this for the simple reason that it prevents (or allows better ability to prevent) someone with a hosting account to write a php script to send out 50,000 emails through the webserver’s default mailserver.

    Putting it through an SMTP server is going to be much more reliable. It’s the simplest solution to get the most reliable email process. If it didn’t work for you, I would take a hard look at your configuration to see if you actually had it configured properly.

    I have checked all spams folders for the addresses that do not receive the messages and that is not the issue. I did however get the following response from Dreamhost…

    “This is just a notification that your message has been moved to our mail blocks queue. This queue is information that our abuse staff uses to determine who is blocking us, why we are being blocked, and at around what time period we are being blocked. Your ticket will be used for information purposes only in helping us get the block removed. You may not receive a response, but you will be instrumental in helping us get this issue resolved faster. Thank you for your mail block report.”

    Comcast, for whatever reason, was blocking Dreamhost. AOL is still up in the air but it seems as if the issues we are having are solely through Dreamhost.

    I had installed and tested an alternate registered user plugin and had the same issues so I had kind of narrowed it down to the host and they have now confirmed and are looking in to it.

    Thank you for you time and quick response! If I have further issues, or additional answers, I will post them here to help anyone else with the same problems.

    Hello Dear all,

    I am new to WordPress and PHP. However I am working with since 2 years.

    I have just shifted my wordpress blog from BigRock to Godaddy.
    Everything working fine. but Mails (notification mails, subscribe mail etc) not working..

    To shift the hosting I have copied the blog folder from bigrock to Godaddy and restored the database of mySql.

    As It seems like Mailing of WordPress uses wordpress Mail servers and not hosting Servers, So I am not suppose to change any smtp settings, right ?

    Then what to do so that I can get the Mails from [email redacted] ?

    Need urgent help

    Thank you in advance

    KruVy – Can you please make your own topic? This one was pretty specific to DreamHost and you’re on GoDaddy.


    I am new here, and don’t know how to make a new topic.
    can you guide me please ?

    Scroll to the bottom of the following page:

    Thank you Very Much. . .

    Word home skillet, I would also recommend reviewing the support topics already listed. You’d be surprised what you can find. Just specifically look for appropriate topics and make sure the topic has more than 1 post otherwise it is just a question with no answer.

    Hummmm, Just reviewed but not getting what I want !
    No surprise !! 🙁

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Auto-Email not working for Free email services’ is closed to new replies.