Support » Plugin: Social Author Bio » Authorship Problems Code

  • Resolved Nathaniell


    Author has entered all relevant information. Links are working fine, and has linked from +profile to /author page. Richsnippets is still showing that I am the author of the post and showing my google+ image.

    What might be the issue?

    2nd Question:

    It seems my theme is having issues displaying the author page, and I’ve seen other people have the same problem. Can I remove the code below for a temporary aesthetic fix til the new version comes out? Not sure if this will affect anything. Basically, I want to remove the author image and ‘circles’ bit.

    echo '<a rel="me" href="'.$googleURL.'" target="_blank" style="outline:none;">';
    				echo '<img src="'.$this->google_avatar( $googleID ).'" alt="Google Circle" /><br>Join my Circle on Google+</a>';


Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Nick Powers


    You can do that but it will not create the link to Google+.

    OK, so that’s required to get the guest poster’s image in the SERPs?

    I have done a test post here

    But rich snippets is still showing “Nathaniell” as the author of the post, not “Roderick”.

    Is there some setting I have wrong or something I’m missing?

    Plugin Author Nick Powers


    I looked at the source and there looks to be other sections in your HTML that references other Google+ profiles. It may be your theme or another plugin. Here is the source:

    Owner <a href="" title="Nathaniell on Google+">+Nathaniell</a> | Follow Us On <a href="" rel="publisher" title="One More Cup of Coffee on Google+">Google+</a></p>

    Plugin Author Nick Powers


    You can see it at the bottom right of your page…

    Ok, yeah. I knew that was there. I thought your plugin would still show the guest author’s pic.

    So in order to show different authors, I’m going to need to remove my google authorship for the site, then only do it through your plugin? ie create my own author profile?

    Plugin Author Nick Powers


    Yes, most people setup a default profile.

    Though, it does look like you have an error the way you put in your Google+ info into your example page.

    You put

    When you should have just put: 114529273674721270601

    That’s why your Google+ image is not coming up in the author page. This needs to be corrected before the SERPs will work.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Authorship Problems Code’ is closed to new replies.