Support » Plugin: Twitter Widget Pro » Authorization Alert Will Not Go Away

  • Resolved callherhappy


    I had two alerts to authorize my account when I signed into my Dashboard. I authorized the account, and one alert went away, but the other alert is still there.

    When I click on it, it takes me to the same page that I used to authorize my account in the first place.

    How do I get rid of this red alert at the top of my Dashboard now?


Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Aaron D. Campbell


    There are two alerts. One for setting up your application with Twitter and putting the credentials in the Twitter Widget Pro settings, and another to actually authorize an account. Once you’ve authorized an account they should both be gone. Are you still having this problem?

    I have the same issue. I set up the consumer keys etc and when I press authorize the authorize account doesn’t go away.

    any suggestions?


    Same issue- red flag to authorize account, but the link goes nowhere, the button to do a new authorization isn’t working. There’s no way to input the username or password. The drop down lists below for username and list are blank and just have a checkmark which I can’t select.

    Same problem here – also, the twitter feed does not show on the site.

    Same problem here, nowhere more info to be found.

    Authorisation on the in applications shows authorisation has been given to the app (site). Still same message. Unclear what to do to make it work.

    aha, there was another discussion on the same topic. The initial instruction could be clearer. DO NOT LEAVE callback URL blank! Use your full website address incl ‘http://’
    It resolved the issue I had. Thanks.

    See full text below:
    Log into the admin section of your site. Under settings (in the left menu) click “Twitter Widget”. There should be a direct link to this page in the admin notices that tell you your consumer key isn’t set up.

    Once there, you’ll see several meta boxes. The top one is labeled “Authenticated Twitter Accounts” and we’ll deal with that in a minute. The second is labelled “General Settings” and has two fields labelled “Consumer key” and “Consumer secret”. Under those fields are step by step instructions for how to obtain the info to put into those fields. Here they are copy/pasted:

    Add a new Twitter application
    Fill in Name, Description, Website, and Callback URL (don’t leave any blank) with anything you want
    Agree to rules, fill out captcha, and submit your application
    Copy the Consumer key and Consumer secret into the fields above
    Click the Update Options button at the bottom of this page
    Make sure to pay attention to step two and do NOT leave the callback URL field blank. Use your site address (or any other valid URL).

    Once those are saved, look back at the first box labeled “Authenticated Twitter Accounts” and click the “Authorize New Account” button. This will take you to Twitter and ask you to authorize the app that you previously created. Once you’ve done that, you will be forwarded back to the settings page and you’ll see your Twitter account listed in the top meta box. Repeat the instructions in this paragraph to authenticate additional accounts if needed.

    Thanks Eddu73 – here is what I had to do:

    1. remove the previous “Consumer key” and “Consumer secret” – then save changes
    2. delete the plugin
    3. add the plugin
    4. follow the steps you listed above
    5. After all that, then I had to edit the plugin and use the ‘Twitter username’ dropdown and select my user name

    Now my site is back up and running as wanted.

    @ Eddu73 and bmanion, thanks for clearing that up!

    @aaron D. Campbell, maybe in the next update you could include a start–up / walk through guide? I ran through the readme / instrux and still hit this snag.

    Love the plugin btw.

    Plugin Author Aaron D. Campbell


    There is a walk through right below the fields where you enter your consumer keys

    What is the walk through called? I felt short of information as well. It’s up and running now though.

    Followed all the steps and i still cannot authorize account, just get the message

    Whoa there! The request token for this page is invalid. It may have already been used, or expired because it is too old. Please go back to the site or application that sent you here and try again; it was probably just a mistake.

    Filled in Callback URL, have also deleted and reinstalled, all to no avail.

    Thank you for the details of the fix.

    I have the same error as ‘closerthanmost’:

    Page URL:

    Whoa there!
    The request token for this page is invalid. It may have already been used, or expired because it is too old. Please go back to the site or application that sent you here and try again; it was probably just a mistake.

    Not entirely sure what I’m doing wrong.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Authorization Alert Will Not Go Away’ is closed to new replies.