WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Widget Pro
[resolved] Authorising Twitter Accounts (28 posts)

  1. dm1905
    Member
    Posted 2 years ago #

    I can't seem to add Twitter accounts to the plugin. There are no input boxes for me to put account details and every time I click Authorize New Account it just takes me to the same page and nothing changes.

    Any assistance would be appreciated.

    http://wordpress.org/extend/plugins/twitter-widget-pro/

  2. Aaron D. Campbell
    Member
    Plugin Author

    Posted 2 years ago #

    You need to go to wp-admin -> "settings" -> "Twitter Widget" and follow the directions under "General Settings" to get a consumer key from Twitter. Once that's done you should be able to authorize accounts.

    Sorry that it's such a pain, but that's how Twitter's new API works.

  3. campbler
    Member
    Posted 2 years ago #

    Having the same issue. I entered my Consumer key and Secret, which worked fine. Still getting the alert to Authorize a Twitter Account, but when I click on the button to do so nothing happens, just reloads the page over and over again.

  4. xitroN
    Member
    Posted 2 years ago #

    I get an error at line 121 :(

    return new WP_Error( $resp['response']['code'], 'Could not recognize the response from Twitter' );

  5. caitplusate
    Member
    Posted 2 years ago #

    Same issue here...what did you guys put in 3rd/4th fields on the app page when you got the consumer key/secret? Maybe I put the wrong sites in the fields and that's the issue?

  6. kylienorton
    Member
    Posted 2 years ago #

    Hello, sorry but I am having the same problems as everyone else. Yes have added consumer key but I get the same message when I try to authorise my account now. I have reinstalled, tried everything. The dropdown boxes for account are empty too. Have emptied cache, etc.
    The request token for this page is invalid. It may have already been used, or expired because it is too old. Please go back to the site or application that sent you here and try again; it was probably just a mistake.
    Please can you advise. Thanks

  7. panmoria
    Member
    Posted 2 years ago #

    Same issue here. Consumer key and secret entered, cannot Authorize New Account...

  8. lizschwartz
    Member
    Posted 2 years ago #

    I am having the exact same issue. I entered a consumer key and consumer secret but cannot Authorize New Account.

  9. dm1905
    Member
    Posted 2 years ago #

    As with the other people who have commented, I entered my consumer key/ secret before making this thread. I have also just now tried re-entering and saving the key and secret and am still having this issue.

  10. Joff Crabtree
    Member
    Posted 2 years ago #

    Add me on to the list - same problem.. what's changed?

  11. hervejodoin
    Member
    Posted 2 years ago #

    Having the same problem.

  12. Aaron D. Campbell
    Member
    Plugin Author

    Posted 2 years ago #

    Are there any similarities here? What host are you on? What version of WordPress and PHP are you running? Anyone willing yo share exactly what they set the name, description, website, and callback to when creating their Twitter application?

  13. jeseph
    Member
    Posted 2 years ago #

    Make sure you tick the "Allow this application to be used to Sign in with Twitter" box and set your blog domain as the callback url. I hadn't done that and was having the same issue. Edited my twitter app and everything is working!

  14. Dale
    Member
    Posted 2 years ago #

    Hi Aaron! Web-Hosting-Service.org (Shared Server), WP 3.5.1, PHP 5.3.19, I set the name, description, and callback to LegendsCrazy.net. Thanks for your efforts to solve this and for the plugin.

  15. Dale
    Member
    Posted 2 years ago #

    I just tried what jeseph suggested and it's working for me now too.

  16. yeseniagn
    Member
    Posted 2 years ago #

    I tried jeseph's suggestions but it didn't work in my case. I already delete cache and cookies just in case, but nothing happens after clicking on 'authorize accounts'

    I'll be waiting to see if a solution is posted.

    Thanks,

  17. panmoria
    Member
    Posted 2 years ago #

    Thanks jeseph, solves the problem for me, all seems to work fine again!

  18. dm1905
    Member
    Posted 2 years ago #

    That's fixed the problem for me as well.

  19. fastagent
    Member
    Posted 2 years ago #

    @joseph
    Thanks! "set your blog domain as the callback url" fixed the problem for me.

    My settings:
    Access level: Read-only
    Callback URL: http://www.my-blog-domain.de <-- Your domain here
    Sign in with Twitter: No <-- "No" seems to be ok

  20. Aaron D. Campbell
    Member
    Plugin Author

    Posted 2 years ago #

    Yep, you definitely have to set the callback URL. The directions say:

    Fill in Name, Description, Website, and Callback URL (don't leave any blank) with anything you want

    Is there a way I could word that better to make it more clear?

    Also, if your problem persists after setting the callback to your site URL (that seems most logical), please start a new support thread.

  21. hervejodoin
    Member
    Posted 2 years ago #

    Problem solved by setting the callback url.

    However, I had to reset my consumer key and consumer secret with the "Reset Key" function on dev.twitter.com and re-enter the new ones in WP for it to work.

  22. lindakwakernaat
    Member
    Posted 2 years ago #

    I've tried that for several times reding this forum before contacting you.
    For now I've deactivated the plugun :(
    By surprise *the black balk on top of the site with New etc* has returned?

  23. caitplusate
    Member
    Posted 2 years ago #

    yup prob solved for me too by resetting callback url!

  24. databell96
    Member
    Posted 2 years ago #

    Yes, it worked for me as well. The callback did the job. The only issue I have left is I initially authorized the wrong Twitter account. I got the right one now but I need to get that other one off the list. How do I do that?

  25. tagleboo
    Member
    Posted 2 years ago #

    Hi Guys,

    Can you help, maybe I am being stupid?

    How do I set this up to use other peoples twitter feeds? I have set it up so I can use my own account, btu I'm sorry, I cant see how to set it up to use other peoples?

    Can you give step-by-step instructions.

    Apologies if I am missing something obvious.

    Tags.

  26. Aaron D. Campbell
    Member
    Plugin Author

    Posted 2 years ago #

    tagleboo - Can you start a new thread? That's really not related to this one.

  27. campbler
    Member
    Posted 2 years ago #

    Since my user key and secret were already tied to a broken account, I just deleted the plugin, deleted my app via Twitter and just started the process over. The suggested process by fastagent worked like a charm. I think I'm up and running now. Thanks everyone for the active thread (and thanks Aaron for the app!).

  28. Rootside
    Member
    Posted 2 years ago #

    Is there a way I could word that better to make it more clear?

    Your instructions are clear. However, I got stuck there as well: I read your instructions, then headed over to Twitter to set up the app. There, it says the callback url can be left blank – so that’s what I did.

    After inserting key and secret in the WordPress admin, your instructions can’t be seen anymore. Logical thinking, but if people keep running into this hurdle, you might want to display your instructions even after key & secret are successfully set up. Alternatively, you could display a hint somewhere.

    Btw, stellar work.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic