Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Authorisation failing with Instagram

  • Resolved dougienisbet

    (@dougienisbet)


    Hi,

    Just installed and followed the instructions for using Instagram. I think there may be something amiss with authorisation. I have entered the access token without any problems but it keeps failing with

    “The access_token provided is invalid.”

    If you look at your own page:
    http://aquoid.com/news/plugins/photonic/instagram/

    this message keeps appearing there too. Perhaps something has changed recently with the way Instagram authorises?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Sayontan

    (@sayontan)

    I did some investigation, and behind the scenes there seems to be something off with the “code” that Instagram is providing. So, you are getting authenticated, but Instagram is still returning an error saying "Matching code was not found or was already used". There are multiple instances of this happening in the past few months, apparently, and StackOverflow is full of reports of this issue. See here, for example. This link includes a potential fix (changing response_type from code to token) that *might* work, but it will take some effort at my end to store the cookie properly.

    I will keep you posted, and thanks for reporting this issue!

    • This reply was modified 2 years, 9 months ago by  Sayontan.
    Plugin Author Sayontan

    (@sayontan)

    I have an update. I have finished doing the code changes, but I had to make some significant changes to how the authentication works. As a net result I have to get my API key approved by Instagram. I have initiated the request, but I don’t know if and when it will be approved. Once approved I will release the next version of the plugin.

    Plugin Author Sayontan

    (@sayontan)

    I have released version 1.59 which definitely doesn’t break. You can see the demo page for instructions and a working example. I have also changed how authentication works (also documented on the demo page).

    However, Instagram refuses to grant Photonic public_content login permissions; I had requested for basic and public_content, but they have only granted basic. As a result, though features such as hashtags and locations are available within the plugin, they will not work until Instagram authorizes it. It is a battle I have been fighting since the last 10 days, and only today did they grant the plugin basic access.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Authorisation failing with Instagram’ is closed to new replies.