WordPress.org

Support

Support » How-To and Troubleshooting » /?author=id redirects to /author/username [security issue]

/?author=id redirects to /author/username [security issue]

  • enposte

    @enposte

    Hi,

    I use 2.3.1 and have pretty permalinks enabled. When I try to invoke the loop by author id the url redirects to the permalink version, which reveals the matching username.

    Example:

    blog.com/?author=id REDIRECTS TO blog.com/author/username

    I don’t want to advertise my username, but at the same time I want clean permalinks.

    Is it possible to disable this?, OR instead have it redirect to:

    blog.com/author/author_id

    Appreciate any help

Viewing 3 replies - 1 through 3 (of 3 total)
  • brianne818

    @brianne818

    I’m also interested in the answer to this question. I can’t seem to find any leads on how to change the author URLs. I also do not want to use the author username, but instead would like to use the nickname.

    Thanks for any insight!

    I’m searching for an answer to this, too.

    I’m searching for an answer to this, too.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘/?author=id redirects to /author/username [security issue]’ is closed to new replies.
Skip to toolbar