WordPress.org

Forums

Testimonials Widget
[resolved] Author won't hide (9 posts)

  1. doremifasolatido
    Member
    Posted 2 years ago #

    Using Testimonials widget and it works well on several sites, however when switching to our custom theme on my current site it suddenly ignores that I've checked "hide author/source?". Instead it shows author and company and I only want company to show, besides the testimonial. So we changed something relating to content in functions file and both author/company was gone. So we changed back and their both still gone. Strange? Do you have any idea? Everything else on the site works perfect.

    http://wordpress.org/extend/plugins/testimonials-widget/

  2. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

    More than likely it's CSS. You probably need a more accurate selector.

    What's the URL?

  3. doremifasolatido
    Member
    Posted 2 years ago #

    It's a client development site, can I send it by mail?

  4. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

  5. doremifasolatido
    Member
    Posted 2 years ago #

    Hi again. After deactivating and removing Testimonials Widget I notice data is still left in wordpress wp_postmeta. How can I clean my database completely from Testimonials widget if I would want that? All starting with "testimonials-widget..."? Cheers, Elena

  6. doremifasolatido
    Member
    Posted 2 years ago #

    Fiddling about. It was simpler than thought. Removed all posts. Made sure settings as I want. Added all posts back and they contain only Company and not author. However, bit strange the settings wasn't possible to change after posts creation. Really really nice widget though! If keeps working like this I will give 5 star!

  7. doremifasolatido
    Member
    Posted 2 years ago #

    Oh, and resolved!

  8. Michael Cannon
    Member
    Plugin Author

    Posted 2 years ago #

    FYI…

    On deactivation, Testimonials Widget doesn't remove data, but I'll work on adding an option to do so.

    I'm still curious about your author show/hide issues. How were you trying to hide them? Via global, widget, or shortcode options?

  9. doremifasolatido
    Member
    Posted 2 years ago #

    Tried hiding author (on widget) through Testimonials -> Settings-> General in WP CMS.

    Ah, and now I get it.

    The widget inherits whatever settings are in global settings once the widget is "created".

    And when I changed global settings in the CMS global, it was overridden by the widget's general settings.

    Of course. And it makes sense. So that you can have different views in different widgets despite global settings.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Testimonials Widget
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.