Support » Plugin: Author Avatars List/Block » Author slug

  • Hi,

    I have a problem with displaying the right user roles.

    On a page I would like to show only users with the ‘author’ role. This is the shortcode I am using: [authoravatars roles=author avatar_size=280 show_name=true min_post_count=0 order=random]

    For the widget I use the same setting, so only the ‘author’ user role is selected. Settings

    The problem, for both the page and widget, is that users with the user role: ‘snax-author’ are displayed together with the ‘author’ user role.

    According to the creators of the Snax plugin, the ‘Snax Author’ role is totally separated from the standard WordPress ‘author’ role. I tried changing the Snax slug with an editor and it works to add a new slug, but the user with the ‘snax-author’ role is still showing up in the grid as ‘author’.

    These are both working for the snax user:


    So they seem not separated..

    Is there a way to show only the /author/ role and remove the snax author user role from the grids?

    Best regards,

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Paul Bearne


    Hi @koningser

    I think the problem is that we are filtering by roles and the Snax Author has/may have more than one role they have the author roles set

    You can use the hiddenusers arts in shortcode to hide the Snax Author

    Otherwise I will have to look and what else we can do


    Hi @pbearne , thanks for your response.

    I checked and only the ‘snax_author’ user role is used. So no double user roles.

    Hiding specific users is not an option.

    I will ask the Snax plugin creators further about it. Because it seems like Snax does use the ‘author’ slug together with the ‘snax-author’ slug.

    Plugin Author Paul Bearne


    please let know what they say


    Hi @pbearne,

    They said that the Snax Author role uses the WordPress /author/ page. So they are right about the fact that it doesn’t use the role, but it does use the wordpress author page. And the slug can’t be changed with an editor.

    I fixed my problem by using the editor role, not ideal, but also not a problem for my case.

    I know that hiding users by id is already possible in author avatars list. On the site I am making there will be a lot of ‘snax authors’ users, which will be registered randomly via the front-end, so hiding them seperately by user id is not an option.

    It may be a good addition to have the option to add users by user id. For me it helps since I will only add 3 to 5 standard wordpress authors, which will always remain constant unlike the snax author role users. The option to add users by user id’s may be valuable in other scenarios aswell.

    Best regards,

    Plugin Author Paul Bearne


    try the whitelistusers arg to show just a subset

    • This reply was modified 3 months, 3 weeks ago by Paul Bearne.

    Perfect! I totally missed to see this option.

    Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.