Support » Requests and Feedback » Author should be able to Update his own page. Not ‘Submit for Review’

  • Hello, When using the classic editor, users that are ‘Authors’ can do the following:
    1. Edit their own pages and click the blue update button. Post is updated immediately
    2. Create a new page, and submit the new page for review.

    However, in 5.0, it seems that authors cannot update their own pages anymore. They don’t have the blue update button. When they hit ‘Submit for Review’, the page essentially gets deleted from public view, as the page becomes a draft that the admin can approve. IF I give the author the priviledge of Publishing Pages, he gets the Update button back, but then he gets to publish whatever pages he wants.

    I’d like to be able to allow my authors to edit and live-update their own pages, but not to be able to publish new pages.

    When I switch back to Classic editor, I get all of the proper functionality back. Possible to make it work ‘correctly’ again in the new version?!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator Otto

    (@otto42)

    WordPress.org Admin

    Did you change the default roles around somehow? Because Authors normally can publish posts.

    There may be a known issue specifically with older posts. More info here:
    https://github.com/WordPress/gutenberg/issues/10154

    I have a similar problem, after the update 5.0 page editing is not possible! Only the white background appears.
    WP should correct this error, I can not edit my post !!

    My website is worthless due to update!!!

    Link pictures

    • This reply was modified 1 month, 1 week ago by  Maklor.
    Moderator Otto

    (@otto42)

    WordPress.org Admin

    @bigli That’s a different problem, and you should make your own topic about it.

    Thank you @otto42, that issue that you referenced #10154 explains my situation exactly. I don’t think I changed any of the default roles. Notice, i’m not talking about posts here, but pages. I don’t necessarily want authors to be able to create new pages, just to be able to update the pages that I assign to them… as we’ve been doing for the past several years! When I switch back to classic editor, the author gets the update button back. But in gutenberg, the is no update button and the page gets reverted to draft when they submit for review. It would be great if the author could still have an update button in gutenberg.

    My authors have: edit_pages and edit_published_pages. I don’t want to give them publish[new]_pages because I only want them tp edit their assigned pages.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Posts and pages are the same thing as far as the code works 😃

    Try having an admin convert the post to blocks, save that and then see if the author can edit?

    Has there been any movement on this bug?

    I too think page authors should be able to edit & publish those edits on already published pages with the “edit published pages” capability.

    The core problem is that the only option for the author is “submit for review” when editing a page they have authored. Prior to Gutenberg, the author was allowed to access the page, edit the page, and update the page as they were the author. So Gutenberg altered the usefulness and definition of the “edit published pages” capability.

    Some might consider giving every author access to the “publish pages” capability, but that is not an acceptable fix as that allows the author to publish any new pages.

    Any fix for this? This is huge!!

    I have authors on my website trying to fix errors or add things to articles, and the only option is to “submit for review” which instantly takes down the article and puts it back into “pending” until it gets approved by an editor again.

    Not at all a solution, but a temporary band-aid: I ended up switching back to the Classic editor. Normal functionality has been restored. I hope this is at least acknowledged by the WordPress team and hopefully fixed soon.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.