Author Pages in WP 3.0 Don't Work with "pretty" permalinks, help! (15 posts)

  1. trusktr
    Posted 6 years ago #

    With ugly URL's, a link such as
    will work just fine.

    However, once "pretty" URL's (permalinks) are enabled, author pages don't work at all (I'm using twentyten theme). This URL should (but won't) work:

    Give it a try and you'll see that the ugly URL will redirect you to the nice URL but it won't work.

    It returns twentyten's default "Not Found" page. Anyone have this problem or know how to fix it?

  2. Need_WP_Help
    Posted 6 years ago #

    Actually both your links result in the same page not found error.

  3. Mark / t31os

    Posted 6 years ago #

    If you use one of the provided permalink structures do the links then work?

    ie. Day and Name, Month and Name or Numeric..

  4. Need_WP_Help
    Posted 6 years ago #

    Nope, always the same no found

  5. Mark / t31os

    Posted 6 years ago #

    Can you switch to another theme temporarily and confirm if the author pages still fail to work.

    You may also wish to consider testing the URL with plugins disabled.

  6. audreycolette
    Posted 5 years ago #

    Hello Mark,

    I am having the same problem with pages (Not found message). It is driving me crazy. For some reason their child pages do work. So maybe thats what missing; they need /page/ before the page name or something like that. Because these pages don't have a specific year, month or day.

    I just tested it in TWO other themes and it doesn't work in those either (Twenty Ten and another one).
    I use the Thematic theme myself. So it must be a problem in WP (I'm using WP 3.01). As an interaction designer NOT using pretty links is professional suicide so I hope this will get fixed....

  7. Mark / t31os

    Posted 5 years ago #

    Pages use the same permalink structure regardless of which structure you choose, other than default (aka none/off).



    Do pages work under any of the provided permalink structures? Do any permalinks work? Have you tried with plugins disabled and have you tried switching theme?

    NOTE: When disabling plugins and/or switching theme you should visit the permalink page and hit save, that way if any plugin or theme was previously adding or modifying the rewrite rules, the rules will now get regenerated minus custom filters/rules..

  8. audreycolette
    Posted 5 years ago #

    Hi Mark,
    I had systematically tried EVERYTHING you mentioned above except disabling plugins and it were only the permalinks to pages that didn't work.
    So I tried disabling some of the plugins today. The culprit turned out to be: "Custom Post Type UI" (WebDevStudios).
    Now the permalinks do work to pages but not to custom post types (of course). Which is a shame.
    I'll try and find a different plugin for custom posts that DOES work with permalinks....

    Thank you for your help.

  9. Mark / t31os

    Posted 5 years ago #

    I've tagged the thread with the custom-post-type-ui tag, that should hopefully get the author's attention if this is a bug with the plugin, hopefully they'll get that fixed.

    Something to consider though, it may well be there's a conflict between the custom post type ui plugin and another, do you have other plugins active? You might wish to try disabling other plugins to, just to see if this has any effect on the issue at hand..

    Happy to hear you tracked down the issue all the same, and glad i could help... :)

  10. audreycolette
    Posted 5 years ago #

    Thank you, yes I noticed it because I was looking through all the other known issues with Custom Post Type UI. The permalinking problem hadn't come up yet.
    You're right I should try other combination / turning other plugins off and CPTU back on. If I find out anything new I will update the info on the thread / aplogize for pointing the finger at them.

  11. audreycolette
    Posted 5 years ago #

    it isn't due to incompatibility with, "All in One SEO Pack". I tried that before.
    And just now I tried disabling "Custom Field Template" and "Custom Post Templates". That didn't help. Still page "Not Found".
    I'm not using any other plugins that could have anything to do with it.

  12. audreycolette
    Posted 5 years ago #

    Just for the hell of it I disabled ALL my plugins except CPTP. Saved permalink structure again and emptied my cache and permalinks to pages do not work.
    So we can safely say Custom Post Type UI has something to do with it.

  13. Mark / t31os

    Posted 5 years ago #

    I think you've done as much as you can, hopefully the author will spot the thread and take a look into the problem.. :)

  14. trusktr
    Posted 5 years ago #

    Oops! I forgot to subscribe to my own topic so i just now read all these replies.

    I've tried deactivating all plugins as well as resetting my .htaccess but the problem persists! It just keeps showing the 404 error for author pages! What could it be?

  15. Twansparant
    Posted 5 years ago #

    I had exactly the same problem and it was driving me mad!
    But I can confirm the problem does come from the 'Custom Post Type UI' plugin. I had a custom taxonomy called 'author' for my blog posts which was screwing up my permalinks. I renamed it to 'author2' and voila, everything worked!

Topic Closed

This topic has been closed to new replies.

About this Topic