Support » Plugin: Yoast SEO » Author Page Redirecting to Homepage due to Yoast

  • Resolved romashah62

    (@romashah62)



    Hello ,

    We have used your plugin where we have disabled Author page in SEO settings and seems like because of that Author page redirects to home page.

    Is it possible that search engine does not show author page but on click of author’s link , it opens author page as required (normal WordPress flow) and not redirect it to homepage?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Destac

    (@destac)

    Well, if you want to go to that page on click to enable the author archives.

    Then go to the setting Show author archives in search results? and select no this should suffice for what you’re doing!

    Plugin Support MariusG

    (@marius_codeinwp)

    Hi @romashah62,

    Yes, it is possible as @destac has mentioned. To do so, go to SEO → Search Appearance → Archives and select:

    • Author archives → Enabled
    • Show author archives in search results? → No
    • This reply was modified 6 months ago by  MariusG.

    Hello ,

    Thanks a lot @destac and @marius_codeinwp.

    It worked for me for archives but I see that there is only one enable/disable button for Date archive.

    Will same this can be possible for date as well?

    for now my date page is also redirecting to homepage and Same as archive I want to show its data but does not want search engine to read it.

    Thanks again.

    Plugin Support Michael Tina

    (@mikes41720)

    @romashah62

    It’s expected that the Date archives in SEO > Search Appearance > Archives Tab should be able to have the settings where you have the archives enabled, but to also have it to not show in the search results directly below that setting. Can you confirm you are able to find this setting?

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.