WordPress.org

Support

Support » How-To and Troubleshooting » Author page is not being found

Author page is not being found

  • The author page URL, for example http://mydomain.net/author/DougLerner/ is always returning a page not found page.

    This is an issue because the author links in both the web UI and in the Jetpack notifications are invalid.

    Is there a setting perhaps that I need to enable the author page to show?

    Thanks,

    doug

Viewing 15 replies - 1 through 15 (of 23 total)
  • Can you access it by using query string (e.g. /?author=1)?

    Unfortunately not. If I enter it by query string:

    http://mydomain.net/?author=1

    all it does is redirect to that URL in my post above, which doesn’t seem to exist.

    doug

    Christine Rondeau

    @crondeau

    Volunteer Forum Moderator

    Can you provide the link to your site, so we can check and see what’s going on?

    Hi, Christine.

    The URL is http://douglerner.net.

    Most of the content is imported from wordpress.com except for a few test posts I made the last few days.

    Until this morning I was running the twenty eleven theme. But somebody said it looked like the problem was that the author was not being credited with the posts. That appeared to be just a twenty eleven theme problem, so I just switched to another theme, and it is showing the authors name (me) by each post now. So that wasn’t the issue.

    Thanks very much!

    doug

    I’m afraid your rewrite_rule is broken.
    Try to disable redirect_canonical by adding:

    remove_filter('template_redirect', 'redirect_canonical')

    on your functions.php, and check again the author page by query string.

    If it still doesn’t work, maybe you can check out the permalink rewrite rules:

    Remove above codes from the functions.php first, and open your header.php, add right after <?php

    print_r( $wp_rewrite ); exit();

    save and reload any page, it will print out the $wp_rewrite object like this:

    WP_Rewrite Object
    (
        [permalink_structure] => /blog/%postname%/
        [use_trailing_slashes] => 1
        [author_base] => author
        [search_base] => search
        [comments_base] => comments
        [pagination_base] => page
        [feed_base] => feed
        [comments_feed_structure] =>
        [feed_structure] => feed/%feed%
        [front] => /blog/
        [root] =>
        [index] => index.php
        [matches] =>
        [rules] => Array

    Copy and paste the result somewhere else. Don’t forget to delete the above code afterward.

    Check on these line:

    [rules] : is there something like ‘author/’?

    I’ve never edited WP code before. This would be in the actual WP code itself?

    I was running 3.3.x until yesterday (it was broken then) and I upgraded to 3.4 today, and it’s still broken.

    Won’t modifying the code interfere with upgrades?

    Is this a general WP bug?

    How would my own rewrite rule have gotten changed?

    Thanks,

    doug

    Also, if you mean the rewrite rule for the query URL, that won’t help because the author links on the web page itself look like http://douglerner.net/author/Doug%20Lerner/ – which is different from both the Jetpack notification author URL (the query URL) and the URL the query URL gets redirected to:

    1. On the blog page: http://douglerner.net/author/Doug%20Lerner/ (bad URL)

    2. In the Jetpack notification: http://mydomain.net/?author=1 (gets redirected to http://mydomain.net/author/DougLerner/ which is also a bad URL.

    doug

    Nope, what I have given is dealing with the theme only, not the core. So, the file I have mentioned is on the ./wp-content/themes/<your theme folder>.

    AFAIC, rewrite rules may have changed by plugins without notice. Usually, by saving permalink options from Setting > Permalink will reload the proper permalink except if the plugin which caused the problem is still activated.

    So, maybe you can check by deactivating plugins first, and re-save the permalink setting. See if it works.

    Redirection from http://mydomain.net/?author=1 to http://mydomain.net/author/DougLerner/ is done by WP by running the redirect_canonical() function on ‘template_redirect’ hook. That’s why I suggest to deactivate it first to see if the author page is accessible from http://mydomain.net/?author=1.

    If it’s accessible, then it’s permalink problem. If it’s not, then we have to find somewhere else that might be the problem.

    That’s just how I debug this kind of problem.

    I see.

    The easiest thing to test seemed to be the permalink settings. So I have tried this:

    1. I changed to the “default permalink” setting (first radio button). That works! The author links are now the query URL format with no redirection and the page shows correctly!

    2. I then tried with my preferred option, the 2nd radio button: http://douglerner.net/2012/06/15/sample-post/. That’s a much nicer format. But unfortunately the same problem occurs again.

    So it looks like a problem with the permalink options, wouldn’t you say?

    Anyway, since choosing the first option works I will just use that for now.

    Thanks very much!

    doug

    p.s. Would I call this “resolved”? I’m not sure. It’s a work-around, but exposes a different bug.

    Agh!!!!

    It started redirecting again. This time to a general 404 error.

    Why?

    doug

    I can see that http://douglerner.net/?author=1 works just fine. What was then redirecting to 404?

    Also, I’m thinking about the .htaccess configuration. Can you provide me with it? Just copy and paste the content of .htaccess file (which is on your server root) here so I can check?

    Arie,

    It must have been a caching thing with Chrome. I noticed the query URL was not redirecting from within Safari. Then I cleared my Chrome cache and it wasn’t redirecting either.

    So I think I’ll not fiddle with the permalinks right now.

    It does seem to be a permalink bug, wouldn’t you say?

    Thanks again.

    doug

    It’s a shame though, because the query URL is the least user friendly format.

    doug

    Yeah, it is possibly permalink/rewrite rules. And indeed query URL is not user friendly format.

    As far as I know, permalink problem can be caused either by plugins or .htaccess file.

    I’m curious to what plugins you have activated. If I may know, maybe I can figure out what plugin which may cause the permalink problem. Have you tried to deactivate them and re-activate the other permalink options?

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Author page is not being found’ is closed to new replies.