Author is incorrect (when writing pages) :-( (9 posts)

  1. lelion
    Posted 9 years ago #

    Hello everyone,

    I just met a strange bug - anyone may have any ideas on that?

    We are making a new WP blog, in which users will be allowed to register. I made a new test registration, so now we have admin + one user registered. When I log in as admin, and write a post, all is OK.

    When I write a PAGE, though, I now suddenly have a new small tab in the right column, which says: AUTHOR.

    What is strange, from the dropdown I have there, I cannot select MYSELF as admin, only the new registered user :(

    Any ideas on that?

    Thank you in advance! :-)

    PS I can't now also write a new post under my name too :(

  2. lelion
    Posted 9 years ago #

    OK, problem fixed with a workaround:

    ( After a second user signed up, actually, it wasn't possible for me to even write a post under MY NAME as admin, just one of the other users... :-( )

    I went to the tab USERS -> then checked my name (admin), then selected CHANGE USER'S ROLE to administrator, UPDATE, and after that I was able again to post under my name (admin), and my name appeared in the list of names in the tab AUTHORS, when writing new posts and pages.

    I had to do this, no matter that I was administrator anyway... just because others signed up and strangely I was still admin, but not able to post as admin, just use other people's names. :-/

    After updating my role from ADMIN to ADMIN, I now can again post as myself:)

    Anyone have met this bug before?

    Is it listed in the TRAC of WordPress? Or maybe some of you know it?...


  3. MichaelH
    Posted 9 years ago #

    I've seen this reported several times here in the forums but have never been able to duplicate the problem.

    I don't believe it is reported in Trac so please consider doing that--I'll try to duplicate it following your steps above.

    Reporting Bugs

  4. lelion
    Posted 9 years ago #

    Thanks, MichaelH!

    For me, it happened on two separate installs, so try to duplicate... :)


  5. lelion
    Posted 9 years ago #

    Bug reported (I was able to reproduce it one more time...),
    here's the link:



  6. Dr Boo
    Posted 8 years ago #

    I had the exact same problem lelion, thanks for the work around!

  7. moshu
    Posted 8 years ago #

    It can NOT be "the same" problem... since this is a 9-10 months old topic about a completely different WP version than you have.

  8. turquoise1
    Posted 8 years ago #

    I just experienced this problem and fixed it with the workaround. I have WordPress 2.5.1. It must occur only under certain circumstances, but it seems to be still around, whether or not the causes are the same as before. I have only three site users: myself (admin) and two editors. As soon as I added the editors, I was only able to post as one of them, not as myself. "Changing" my status to Administrator worked. I can now post as myself, so I'm happy. It is a strange thing though ...

  9. luckyblog
    Posted 8 years ago #

    Had this problem on 2.5.1 and the workaround worked for me thanks!

    I have a site where I expect to get more and more users (well, hope anyway ;-) ), I'll see if the problem recurs when more people add themselves...

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.